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Introduction
IFC - Industry Foundation Classes - is a neutral file format that makes it possible to exchange 
information between different CAD systems and other systems in the building and facility 
management sectors. The IFC format is ISO-certified and can be integrated into any existing 
quality assurance polices your office may have. IFC is developed in part by the IAI - the 
International Alliance for Interoperability. Today there are over 600 members with 13 chapters 
around the world.
For more information, see: http://www.buildingsmart.com/.
GRAPHISOFT has played an active role within the IAI organization since 1996 and supports the 
IFC standard, which enables ArchiCAD to communicate with other disciplines within the context 
of the building model, and to coordinate a building project entirely in 3D. The building model can 
also be exported back to literally hundreds of other systems that support IFC.
BIM, or “Building Information Modeling,” is one of the biggest advances in the building 
industry’s working methods since the introduction of CAD software. BIM is NOT synonymous 
with 3D projects. Three-dimensional geometric representation is only one part of the digital 
deliverables. A project includes non-graphical information, such as calculations that are used in 
surveying, facility management and energy calculation. A prerequisite for a successful BIM 
project is that intelligent information can be exchanged between different software and even 
operating systems, throughout the stages of the building process. This interoperability demands a 
neutral file format with an open standard that supports different systems. IFC is such a system, 
enabling us to synchronize building models between the disciplines much more easily.
With its user-friendly interface and wide latitude for customization, ArchiCAD enables users to 
communicate in an efficient way, to focus on the needed elements and to locate any errors in 
design development via IFC data exchange. This chapter has been created to provide ArchiCAD 
users an insight into the IFC standard and how it works in ArchiCAD.

Model View Definitions

File Types

IFC Data Types

IFC Element Types

IFC-Related Functions

Working with IFC Data

Export Functions

Import Functions

Change Detection

IFC Translators

Model Filter
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Model View Definitions
Industry Foundation Classes (IFC) are the open and neutral data format for openBIM. ArchiCAD 
supports the import, export and data structure of the latest IFC release: IFC2x Edition 3 (third 
release of the IFC 2x Platform, IFC2x3 for short) - more specifically, its latest version, the so-
called Technical Corrigendum 1, published in July 2007.
An IFC View Definition, or Model View Definition, MVD, defines a legal subset of the IFC 
Schema and provides implementation guidance or agreements for all IFC concepts (classes, 
attributes, relationships, property sets, quantity definitions, etc.) used within this subset. It thereby 
represents the software requirement specification for the implementation of an IFC interface to 
satisfy the Exchange Requirements.
Model View Definitions are either defined within buildingSMART International, or by other 
organizations and interest group.
ArchiCAD IFC Export and Import supports the following Model View Definitions:
• The Coordination View was the first Model View Definition developed by buildingSMART 

International and is currently the most widely implemented view of the IFC scheme. The 
main purpose of the Coordination View is to allow sharing of building information models 
among the disciplines of architecture, structural engineering, and building services 
(mechanical). It contains definitions of spatial structure, building, and building service 
elements that are needed for coordinating design information among these disciplines. The 
IFC2x3 Coordination View is the built-in and default standard supported by ArchiCAD.

• The Coordination View (Surface Geometry) is a simplified publishing format (i.e. a subset) 
of the Coordination View. This format is suitable for viewing (since all IFC viewers support 
this format), design coordination, clash prevention during design, and clash checking. 
“Coordination View (Surface Geometry)” means that every element will be exported with its 
BREP (boundary representation) geometry. This method comes closest to reproducing the real 
shape of the element, together with its specialized sections, connections and solid operations. 
(However, the element’s parameters are lost, and BREP elements from an imported IFC file 
are transformed into non-editable elements.)
Note: In earlier ArchiCAD versions, the Coordination View (Surface Geometry) was known 
as Simplified view (BREP only). Other applications may use “Simplified View” or 
“Presentation View” instead.

• There are several other Model View Definitions (generally the extended versions of the 
Coordination view) specified by organizations or development teams outside of 
buildingSMART International. An example is the Concept Design BIM 2010 model view 
definition that is supported/required by the General Services Administration (US GSA), 
Statsbygg (Norway) and Senate Properties (Finland). The additional MVDs require programs 
to provide IFC data above and beyond those of the Coordination View standard - such extra 
data include Classification Reference, Space Occupant, Actor and specific property sets and 
properties. ArchiCAD’s IFC interface provides the possibility to define, export and import 
these data types. As a result, users will be able to fulfill for example the GSA-specific 
classifications according to UniFormat and the various OmniClass classes; the COBie 
(Construction Operations Building Information Exchange), Statsbygg and Senate Properties 
regulations.
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For more information, see IFC Data Types and Working with IFC Data.
All Model View Definitions can be extended by add-on model view definitions which support 
additional exchange requirements: 
• the Quantity Take-off add-on view adds the ability to transmit base quantities for all spatial 

and building elements
• the Space Boundary add-on view adds building elements to space relationships to support 

models in thermal and energy analysis
• the 2D Annotation add-on view supports the exchange of additional 2D element 

representations and annotations of building models
ArchiCAD supports all of these additional data types.
See Export Options of IFC Translators.
IFC 2x3 Reference Guide 5



File Types
ArchiCAD supports the export and import of the following IFC data file formats: 

• .ifc: the default IFC exchange format using the STEP physical file structure
• .ifcZIP: IFC data file using the ZIP compression algorithm. It is the compressed version of .ifc 

or .ifcXML. An .ifcZIP file usually compresses an .ifc down by 60-80% and an .ifcXML file 
by 90-95%.
Note: .ifcZIP is compatible with e.g. Windows compressed folders, WinZip, etc. So if the 
recipient cannot read .ifcZIP, then a ZIP extractor application can open the file into .ifc or 
.ifcXML format.

• .ifcXML: IFC data file using the XML document structure. This format is recommended for 
architects whose partners’ applications cannot read the original .ifc format, but can manage 
XML databases (such as budget, energy calculations, etc.). This format delivers the same 
model information as the plain .ifc format, but the elements and their properties are stored in a 
more informative structure. An .ifcXML file is normally 300-400% larger than an .ifc file.
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IFC Data Types
This chapter summarizes the main IFC data types available in ArchiCAD.

IFC Entity

IFC Container

IFC Type Product

IFC Model Hierarchy

IFC Attributes and Properties

IFC Classification Reference

IFC Assignments
IFC 2x3 Reference Guide 7



IFC Entity
In an IFC model, the project information (generated, for example, from an ArchiCAD project) is 
represented as a set of IFC Entities - such as elements, materials, and their relationships. Each 
IFC Entity (for example, an IfcWall) includes a fixed number of IFC Attributes, plus any number 
of additional IFC Properties. The IFC scheme encompasses several hundred entities, of which the 
building element-type entities (such as IfcWall and IfcColumn) represent only 25.

Some IFC Entities express characteristics of other entities. Some of these correspond to 
ArchiCAD attributes. These correspondences are mapped automatically when the IFC model is 
generated or exported, or when the IFC model is imported.

ArchiCAD Attribute IFC Entity
Layer IfcPresentationLayerAssignment

Fill Type / Composite IfcMaterial / IfcMaterialLayerSet / IfcMaterialList

Material IfcSurfaceStyleRendering

Complex Profile IfcProfileDef
8 IFC 2x3 Reference Guide



IFC Container
IFC Container is an IFC entity that does not have its own body geometry, but its components 
contain the geometry and the material relations. For example, a Curtain Wall placed in ArchiCAD 
is an IFC Container (IfcCurtainWall), whose components include frames (IfcMember) and panels 
(IfcPlate). Similarly, a stair (IfcStair) imported from an external application is also an IFC 
Container, whose geometry-defining components are typically IfcStairFlight, IfcSlab (with 
predefined type Landing), IfcRailings, or any kind of entity such as the simple 
IfcBuildingElementProxy.
IFC 2x3 Reference Guide 9



IFC Type Product
An IFC Type Product is an IFC Entity that defines a particular style/type of other entities by 
relating to them with common IFC Attributes and Properties. For example, IfcWindowStyle is an 
IFC Type Product, to which many windows (IfcWindow) refer.

Note: The data (that is, Properties and Attributes) of an IFC Type Product (which can be 
imported via an IFC model, or automatically generated within ArchiCAD, as for example 
when placing windows) are not editable. They can be viewed in IFC Manager using the 
“Element types” view.

See IFC Manager.
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IFC Model Hierarchy
An IFC model is composed of IFC Entities built up in a hierarchical order. As shown in the 
following illustration, each story level (IfcBuildingStorey) has its corresponding story in 
ArchiCAD - for example, when you import an IFC model, or apply IFC Manager for your current 
project.
See IFC Manager.

Note: 
• IfcSite is the geographic position of the IfcProject. It can have a geometry but a geometry 

is not required. In ArchiCAD, site geometry is represented by Mesh elements and Site-
type Objects and elements with “Site Geometry” Element Classification.

• ArchiCAD can handle, and so can import, one building (IfcBuilding) only. But it can 
import more than one IfcSite, even though the IfcSite is above the IfcBuilding in the 
hierarchy. Thus, when importing an IFC file that contains multiple buildings, you can 
choose only one to import.

See Step 4: Building or Site Selection.
• However, other applications can export a building’s topography into multiple IfcSites. In 

this case, importing the IfcBuilding will import all of the IfcSites, merged into the one 
IfcSite that actually contains the imported IfcBuilding. The result is that you will end up 
with a single IfcSite and a single IfcBuilding, but the IfcSite includes all of the IfcSites.
IFC 2x3 Reference Guide 11



IFC Attributes and Properties
IFC Attributes are the main identifiers of IFC Entities. The names of IFC Attributes are fixed, 
having been defined by buildingSMART as part of the IFC 2x3 scheme.
In the case of ArchiCAD, most of these IFC Attribute names are derived from the project. For 
example, the IFC Attributes of an IfcWall building element: 
• GlobalId: the Globally Unique Identifier of the IfcWall in the IFC model.
• OwnerHistory: the assignment of the information about the current ownership of the IfcWall.
• Name: its derived value is the same as IfcWall’s ArchiCAD ID.
• Description: an optional textual description with a unique value.
• ObjectType: an optional label-type ID with custom value.
• Tag: a label identifier with value derived from and equal to the IfcWall’s ArchiCAD GUID 

(not equal to IFC GlobalId).
Note: In order to provide fast access, OwnerHistory is directly attached to all independent 
objects, relationships and properties. Its components and values are derived from project data 
and hidden in the ArchiCAD user interface. It includes for example the owning actor 
(OwningUser) of which multiple values are derived from the Person and Organization data.

See IFC Options.

IFC Properties are additional (mostly IFC Element Type-specific) parameters assigned to an IFC 
Entity. IFC Properties can be either standard (conforming to the rules of the IFC scheme defined 
by buildingSMART), which are stored in property sets whose names begin with the prefix 
“Pset_”; or they can be custom, which are created by the exporting application using any property 
name and stored in any property set (the names of these property sets usually contain the name of 
the exporting application).
Examples:
• Library Part parameters can be automatically exported from an ArchiCAD model as custom 

IFC Properties.
See IFC Options and IFC Translators > Export Options.
• Usually (if you are not using mapping rules), a Library Part parameter is exported from 

ArchiCAD under its localized name, and with a property set having the prefix 
“AC_Pset_(Libpart name)”.
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• ArchiCAD’s “Renovation Status” property is automatically converted into a custom IFC 
Property, found under the AC_Pset_RenovationAndPhasing property set.

Some standard IFC Properties have corresponding ArchiCAD properties. In these cases, the 
values are transferred between them during IFC model import and export. These IFC Properties 
thus have derived values, which can be edited using the corresponding ArchiCAD property. 
Among these, the most important IFC Properties are “IsExternal” and “LoadBearing”, whose 
ArchiCAD equivalents are the “Position” and “Structural Function” classification properties.
IFC 2x3 Reference Guide 13



IFC Classification Reference
A Classification Reference (IfcClassificationReference) is used for arrangement of IFC elements 
into a category. You can assign an Item Reference identifier, a classification Name attribute and 
some other optional parameters to all project elements (such as the building, the stories, the 
building elements, or the zones). For example, classify building elements by the U.S. GSA 
standard categories such as OmniClass, UniFormat etc.
You can classify elements with this system both in IFC Manager and the element Settings dialogs.
See Custom IFC Properties and Classification Reference.
14 IFC 2x3 Reference Guide



IFC Assignments
Use the IFC Assignments (IfcRelAssigns) to define the relationship between the different project 
elements. Each assignment type can have its own IFC Attribute (the most significant is the Object 
Type), and standard and custom IFC Properties. ArchiCAD supports four types of IFC 
Assignments whose functions are as follows:
• IFC Group (IfcGroup): Use this to group any project elements (building element, story etc.) 

together. For example: the column and beam components of a frame are grouped together.
• IFC Zone (IfcZone): Use this to group IfcSpace elements (the equivalent of ArchiCAD 

Zones) together. For example: ArchiCAD Zones having the identical function are grouped 
into an IfcZone named e.g. “Security Zone.” 

• Actor (IfcActor): Use this to assign an actor (person and/or organization) and its role (e.g. 
owner, architect, client) to any project element (project, story, building element etc.). 
Example: assign the Actors “Project Architect” and “Project Client/Owner” (GSA 
requirements) to the (Ifc)Project.

• Space Occupant (IfcOccupant): Use this to define the occupancy relationship between an 
actor (person and/or organization) and one or more IfcSpaces or their groups (IfcZone).

Use IFC Manager to create any type of the abovementioned assignments.
See Assignments.
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IFC Element Types
Each ArchiCAD modeling element, building-type object and annotation element has a mapped 
pair in the IFC structure (IFC element type). The following table summarizes the default IFC 
element types converted from the ArchiCAD elements.

ArchiCAD 
Element

Mapped IFC 
Element Type

ArchiCAD 
Object > 
Subtype

Mapped IFC 
Element Type

Wall IfcWall or 
IfcWallStandard Case 
(depending on the 
geometry)

Object > Wall IfcWall

Door IfcDoor Object > Door IfcDoor

Window IfcWindow Object > Window IfcWindow

Skylight IfcWindow Object > Opening IfcOpeningElement

Roof IfcSlab (predefined type 
Roof)

Object > Roof IfcSlab (predefined type 
Roof)

Shell IfcSlab (predefined type 
Roof)

Object > Beam IfcBeam

Beam IfcBeam Object > Column IfcColumn

Column IfcColumn Object > Pile IfcPile

Slab IfcSlab (predefined type 
Floor)

Object > Slab IfcSlab (predefined type 
Floor)

Stair IfcStair Object > Precast Slab IfcSlab

Morph IfcBuildingElementProxy

Ramp (Stair 
Maker)

IfcStair Object > Plate IfcPlate

Mesh IfcBuildingElementProxy 
(as IfcSite geometry)

Object > Member IfcMember

Curtain Wall IfcCurtainWall Object > Tendon IfcTendon

Zone IfcSpace Object > Stair IfcStair

Wall End IfcWall Object > Stair Flight IfcStairFlight

Corner 
Window

IfcWindow Object > Ramp IfcRamp

Grid Element IfcGridAxis Object > Ramp 
Flight

IfcRampFlight
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Notes:
• The export of Grid elements and 2D elements occurs only if the appropriate option in the IFC 

Translator is enabled.
See Model Element Filter.
• The IFC standard does not support the intelligent export of dimensions. Therefore, exporting 

dimension elements will result in these elements falling apart into lines and texts 
(IfcAnnotation elements).

• In the case of Objects, if you can classify a Subtype (for example, an Object having a Wall-
subtype), then the object will be exported accordingly (e.g. as an IfcWall). Certain subtypes 
are automatically assigned the IFC element types that correspond to their group name (e.g., in 
case of the “Bed,” “Seating” or “Table” subtypes, its IFC type is automatically set to 
“IfcFurnishingElement”, since its group name is the “Furnishing” subtype). If no subtype 
exists that corresponds to an IFC element type, then we recommend that you search for a 
subtype under IFC2x_Base_Object (see illustration below), or use the “Element 
Classification” option in the Tags and Categories panel of Object Settings (see later). If no 

Grid System IfcGrid Object > Railing IfcRailing

Lamp IfcFlowTerminal Object > Curtain 
Wall

IfcCurtainWall

Dimension IfcAnnotation Object > Furnishing IfcFurnishingElement

Level 
Dimension

IfcAnnotation Object > Wood Truss IfcBeam

Text IfcAnnotation Object > Foundation IfcFooting

Label IfcAnnotation Object > Footing IfcFooting

Fill IfcAnnotation Object > Space IfcSpace

Line IfcAnnotation Object > Covering IfcCovering

Arc/Circle IfcAnnotation Object > Reinforcing 
Bar

IfcReinforcingBar

Polyline IfcAnnotation Object > Reinforcing 
Mesh

IfcReinforcingMesh

Radial 
Dimension

IfcAnnotation Object > Wall End IfcWall

Angle 
Dimension

IfcAnnotation Object > Electrical 
Element

IfcFlowTerminal

Spline IfcAnnotation Object > Flow 
Fitting

IfcFlowFitting

ArchiCAD 
Element

Mapped IFC 
Element Type

ArchiCAD 
Object > 
Subtype

Mapped IFC 
Element Type
IFC 2x3 Reference Guide 17



such IFC element type exists, then the Object will be exported as a general solid object 
“IfcBuildingElementProxy”).

An ArchiCAD’s element classification affects that element’s IFC export type. The mapping 
displayed in the above table shows the default and recommended situation, when an element’s 
element classification value (set under “Element Classification” in the Tags and Categories Panel 
of element Settings) is set to “ArchiCAD Type”.
But in some cases, you will have to model building elements that have no exact counterpart in the 
ArchiCAD toolbox; you will have to use an existing tool. For example, you might use the Wall 
tool to model a curved beam, or the Slab tool to model a ceiling. Using the default “ArchiCAD 
Type” value for these elements would export them as IfcWall or IfcSlab, respectively. To avoid 
this, use ArchiCAD’s Element Classification feature to handle these non-standard modeling and 
export tasks correctly. Except for annotation elements, all ArchiCAD elements can be classified 
for IFC export purposes, so, for example, the curved beam modeled with Wall tool can be 
exported as IfcBeam by modifying its Element Classification to “Beam”.
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Similarly, your ceiling modeled with the Slab tool can be classified as “Ceiling”. This way, that 
Slab will be classified as an IfcCovering element of the Ceiling predefined type in the IFC 
hierarchy of the architectural model (these settings can be confirmed using IFC Manager), as well 
as in the IFC model that will be exported.
See also IFC Manager.
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Notes:
• Do not change an ArchiCAD element’s default classification unless your modeling logic 

requires such a change. In every other case, use the default “ArchiCAD Type” classification. 
For example, there is no reason to classify an ArchiCAD Wall as a “Wall”: this would produce 
the same result as retaining the default value of “ArchiCAD Type”, which automatically 
exports your wall as an ifcWall.

• Element Classification has another advantage, not directly related to IFC exchange: you can 
use Find & Select and Interactive Schedules to filter by “Element Classification” criteria. For 
example, you can select or list just the slabs that were used to model ceilings.
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Element conversion rules according to IFC element types at IFC model import:
• If the imported IFC element type (e.g. IfcBeam) exists as a model element in ArchiCAD, then 

that editable (non-GDL-based) element (e.g. Beam) will be created, provided that its 
geometry is “extruded” and can be created using the ArchiCAD tool (e.g. a horizontal beam 
created with the Beam tool).

• If the imported IFC element type exists as a non-GDL ArchiCAD model element type (e.g. 
Beam), yet has a “BREP” geometry or cannot be created using the corresponding ArchiCAD 
tool (or if no such corresponding tool exists), then an Object having the appropriate subtype 
(e.g. Beam subtype) is created, or else a Morph having the appropriate Element Classification 
(e.g. “Beam”) is created.
Note:
• Whether the created element is an Object or a Morph depends on the Geometry 

Conversion import option of the IFC Translator being used.
            See Import Options of IFC Translators.

• “Extruded geometry” is the standard IFC geometry representation, which retains the 
elements’ parameter values (such as thickness, height, location of reference line or edge, 
skin structure of composite materials) - however, certain specialized sections are not 
retained. “Boundary representation” (BREP) geometry method comes closest to 
reproducing the shape of the element, together with its specialized sections and 
connections (but the element’s parameters are lost).

• Naturally, whether a given element or element type is imported at all depends on the 
Model Element Filter settings or the import options of the IFC Translator.
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IFC-Related Functions
The following is a summary of the commands and functions that are affected by the management 
of the IFC model and data (in the event that the IFC Add-On has been installed).

Note: To handle IFC, the IFC 2x3 Add-On is automatically inserted into the ArchiCAD 
environment during ArchiCAD installation. The IFC add-on is updated with each ArchiCAD 
Hotfix. However, it is possible that the Add-On is updated between ArchiCAD Hotfixes. 
Check the latest available IFC add-on release at: http://www.graphisoft.com/support/ifc/.

The following commands can be accessed from the File menu after the IFC Add-on is installed:

IFC Data Handling
• IFC Manager
• Manage IFC Properties (Element Settings)
• IFC Scheme Settings
• IFC Options
• Find & Select
• Interactive Element Schedule
See Working with IFC Data.

IFC Export Functions
• Save as
• Merge to IFC Model
See Export Functions.

IFC Import Functions
• Open
• Merge
• Update with IFC Model
See Import Functions.

Detect IFC Model Changes
See Change Detection.

IFC Translation Setup
See IFC Translators.
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Working with IFC Data
You can manage IFC Data in the following ways: 
In the Tags and Categories panel of Element Settings, you can assign and view IFC Attributes, 
standard and custom IFC Properties, and IFC Classification References. In addition, use Element 
Settings to carry out Element Classification (by IFC Element Type, Structural Function, and/or 
Position).
See Element Settings Dialog.
Use the IFC Manager to get an overview of the IFC hierarchy of the current ArchiCAD project; to 
navigate between that IFC model hierarchy and ArchiCAd elements; to manage these IFC data 
from a global perspective (assign values, create new data, modify data); and to create IFC 
Assignments (a function not available anywhere else).
See IFC Manager.

Note: Naturally, the Attributes, Properties and Classification References defined in the IFC 
Manager are immediately reflected in the relevant Element Settings dialogs, and vice versa.

In each project, you can store your custom IFC Properties and the Property Sets they are 
contained in, in so-called Schemes (.xml files). Use the IFC Scheme Settings command to share 
(export and merge) custom properties files between ArchiCAD projects.
See IFC Scheme Setup.
The IFC Options command also provides a way for global-level data management. Use IFC 
Options to assign the OwningUser data to the IFC model (part of the OwningHistory), using the 
Person and Organization data. Also in IFC Options, you can assign mapping rules between all 
Library Part parameters and their corresponding IFC Property. Library Part parameter mapping 
will affect both IFC export (since Library Part parameters can be exported as particular standard 
or custom IFC properties) and IFC import (since incoming IFC properties can be interpreted as 
particular Library Part parameters). The mapping rules can be stored in .xml files.
See IFC Options.
Use the Find & Select command to search for any elements by their IFC Attribute, IFC Property, 
or Classification Reference values.
See Find and Select Elements by IFC Data.
Use the Interactive Element Schedule to list any elements by their IFC Attribute, IFC Property, or 
Classification Reference values.
See Scheduling Elements with IFC Data.
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Element Settings Dialog
ArchiCAD elements created out of imported IFC model elements display their standard and 
custom IFC data, at the element level, in their respective Settings dialog boxes (Tags and 
Categories panel).

Note: Imported IFC elements and their properties (depending on the translator used) generally 
(by default) are protected against modification in accordance with the Reference model 
concept. Of course, by activating the layers of those elements, those elements too can be 
modified as needed.

Similarly, you can use the IFC options in Element Settings to manage (define and edit) IFC data 
(Attributes, standard and custom Properties and Classification References) for searching (Find & 
Select), scheduling, and IFC model export purposes. New IFC data can be added to (or removed 
from) the related elements manually or automatically based on predefined rules in the Manage 
IFC Properties dialog.
See Creating New IFC Data.
The new data will appear under IFC Properties, where you can assign values according to the 
particular value type (single or multiple value, Real, Integer, Label, Text, or Boolean etc.)
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IFC Manager
The IFC Manager (File > File Special > IFC 2x3) provides a hierarchical overview of the current 
project’s IFC model database with the following functions:

• Collects and lists all the IFC Entities generated from the elements of the current ArchiCAD 
project and/or contained in the opened/merged IFC models

• Collects and lists all IFC Attributes, Properties, Property Sets, Classification References and 
Assignments of the entire project by project hierarchy and by Entity types

• Enables you to create, delete and edit IFC data
• New custom IFC Properties and Classification References can be defined manually or 

automatically based on predefined rules
See Creating New IFC Data.
• Enables you to create and delete IFC Assignments
• Updates the IFC model with the modifications of the ArchiCAD project
• Navigates easily between the ArchiCAD model and the IFC model
• Filters the IFC model by visible layers
• Filters only the IFC data items having values in the current project 
• Finds elements (IFC Entities) both in the IFC and ArchiCAD models by their IFC GlobalId 

(Globally Unique Identifier) Attribute
• Displays IFC Type Products
• Displays IfcSpace containments
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See the IFC Manager Tree View in IFC Options.
The upper left side of the IFC Manager, the containment tree, displays the IFC model hierarchy 
and lists IFC Entities one by one according to their “IFC Element Type” classification.
See IFC Model Hierarchy.
The right side of the dialog box displays the IFC Attributes, Property Sets, Properties and 
Classification References of any element you have selected in the tree (in case of multi-selection, 
the IFC data of the last-selected element are shown). At the top of the list, the numbers of 
selected/editable elements are shown.
The IFC Manager palette is a modeless dialog box, so you can keep it open while working in the 
ArchiCAD project:
• If elements are created or deleted in the ArchiCAD model, the containment tree will not 

register these changes automatically. If a refresh is needed, a message appears below (“Tree is 
not up-to-date!”). To synchronize the containment tree of the IFC Manager with the project 
content, click on the Synchronize tree to plan button above the list. (If this button is grey, it 
means the tree view is up to date.)

• To find and select IFC Entities of the tree in the ArchiCAD model, just select them (multiple 
selection also works) in the tree and click Show selected tree elements button.. The program 
then attempts to display and select the elements in the active window (Floor Plan or 3D view 
only). In a Floor Plan view, if the element is not visible, then ArchiCAD automatically 
switches to the Home Story of the selected element. If it is still not visible, then a warning 
dialog appears. In a 3D view, if the element is not visible, a warning dialog appears.

• To find and select ArchiCAD model elements in the containment tree, just select them 
(multiple selection also works) in the current view (Floor Plan or 3D view) and click the 
“Show selection in tree” button. (It is recommended to use this button if the tree structure has 
already been synchronized with the model.)
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By default, the containment tree shows the entire IFC model and data of the current ArchiCAD 
project. By activating the List Visible Elements Only button, you can narrow the containment tree 
to those elements that are on visible layers only in the current view. Thus, by clicking the button, 
you can switch the tree and data content between the entire IFC model and just the visible IFC 
Entities.

Note: If you use the button to narrow the data content, and then switch views in the project, 
you can update the data shown in the IFC Manager by using “Synchronize tree to plan”, 
because different views may have different active layers.
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You can locate elements in the containment tree based on their IFC GlobalId (Globally Unique 
Identifier) Attribute. Switch to the search mode using the Find by GlobalId tool. Just type the IFC 
GlobalId or any portion of it into the empty field below the tool, and then click “Search by 
GlobalId”. Choosing any item in the Search result list will select and show the assigned element 
in the containment tree. Clicking “Show selected tree element” finds and select the element in the 
ArchiCAD model too.
The IFC Manager locates and displays all the IFC Type Products that exist in the project, plus all 
the elements which refer to them.
See IFC Type Product.
To see this, switch to the Element types view mode using the third icon underneath the 
containment tree. In the appearing list, select the type/style or its related elements to check their 
IFC Data on the right side of the IFC Manager. However, the IFC Attributes and Properties of the 
Type Products are not editable here.
IFC 2x3 Reference Guide 29



Creating New IFC Data
Note: Unlike the IFC Manager, you can use Element Settings to assign new IFC data not just 
to building elements, but to any IFC Entity (including Assignments, Stories, Sites, Buildings, 
etc.).
Note: In Teamwork, the following data in the IFC Manager can be reserved and modified: 
IfcProject, IfcBuilding, IfcSite and the Assignments. IFC Properties of model elements (e.g. 
IfcWall, IfcColumn, IfcBeam) can be modified via IFC Manager only if those elements are 
not reserved by any other user.

IFC Attributes and Standard Properties
Both of these can have values that are optionally assigned or else derived.

To assign an optional Attribute or standard Property to an element, check the box in front of the 
element. Use the Value field to define its value depending on the value Type (e.g. Label, Integer, 
Boolean). Any element that is not assigned a value will be exported that way.
Derived values will come from a source of existing ArchiCAD data. These values are shown in 
grey, indicating that you cannot modify these values here (only at their source, where that 
particular ArchiCAD value comes from). If the checkbox in front of the element is checked, it 
means that this value will be exported together with the element. The boxes of properties (e.g. 
IsExternal or LoadBearing) having a value of “undefined” are not checked; this means that the 
Properties will not be exported.
Examples for an IfcBeam:
• The Name Attribute is derived from the ArchiCAD Beam-classified element’s ID parameter 

(found in the Tags and Categories panel of Element Settings).
• The value of the IsExternal property (Pset_BeamCommon), either “True” or “False”, is 

derived from the corresponding ArchiCAD element’s Position classification (either 
“Exterior” or “Interior”).

• The value of the LoadBearing property (Pset_BeamCommon), either “True” or “False”, is 
derived from the corresponding ArchiCAD element’s Structural Function classification 
(either “Load-Bearing Element” or “Non-Load-Bearing Element”).

Derived Standard Properties can also originate from the mapping of Library Part parameters.
See IFC Options.
30 IFC 2x3 Reference Guide



Custom IFC Properties and Classification Reference
Use the Create Property/Classification option to create new custom IFC Properties or 
Classification References. Alternatively, use the Apply Predefined Rule commands to create them 
automatically.
Click the Create Property/Classification button to create and assign a name to the new custom IFC 
Property or Classification Reference.

To create a new custom IFC Property:
1. Define a name for the new custom Property Set; or else choose from the list of existing 

Property Set names defined previously for the same element type (click the icon to access this 
list). For example, if you are creating a new Property for an IfcWall, the list contains all the 
Pset names earlier assigned to other IfcWalls.
Note: To avoid errors (and to keep the standard property definition rules), do not use the 
standard PSET_prefix when giving a name to your custom Property Sets.

2. Define a name for the new custom Property.
3. Set the type of the new Property (single, enumerated, complex, etc.)
4. According to the Property type, set its value type to label, text, integer, boolean etc.
To create a new Classification Reference, just assign it a name. Here, too, you can choose from 
the list of existing Classification Reference names defined previously for the same element type 
(click the icon to access this list).
Having defined a new Property Set, Property or Classification, you can apply these to other 
elements too, not just the one you are editing. For example, if you have created the new data for a 
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selected IfcWall element, you can apply the new data to all elements of the same type as the 
selected one (all IfcWall entities), or to all elements in the IFC altogether (all IfcWalls, 
IfcColumns, IfcBeams, etc.): Use the “Add new items to scheme for...” options.
These options will also work for new elements to be created in the future (any new IfcWalls, or 
any new element, depending on the chosen option) will automatically be assigned this data. The 
Properties that are thus created are added to IFC Scheme Setup.
See IFC Scheme Setup.

Newly created IFC data will appear in the defined Property Set or “Classification Reference” 
folder in IFC Manager, as well as in the element Settings dialog among the listed properties. 
Assign values to the new data according to its value type. For example, a Classification Reference 
data has 6 available items (the most important ones are the name (Name) and the identifier 
(ItemReference) of the classification reference data) for defining/editing. Such newly created IFC 
data appears with a red X in front, meaning that you can delete them at any time. If a Property Set 
no longer contains any Properties, it will be deleted from the list automatically. To rename a 
Property or Classification Reference, click on the name, then re-write it.
Custom IFC Properties (and Property Sets) may also be created through the IFC Scheme Setup 
command (these Settings will also contain the data created by using the above-mentioned “Add 
new item to Scheme for...” option). These data can only be edited (deleted, renamed) using the 
IFC Scheme Setup command.

Assignments
To create a new Assignment , do the following:
32 IFC 2x3 Reference Guide



1. Switch to Assignment definition mode by clicking the Assignments icon.
2. Select the Assignment type by clicking on the IFC Groups, IFC Zones, Actors or Space 

Occupants item.
3. Click the New button under the Assignments window section.
4. Select the new item, whose default name starts with New... and ends with the created 

Assignment type (e.g. NewGroup).
5. Give a (new) name to the new Assignment on the right side of the dialog in the Name 

Attribute field.
6. Edit the Attributes and/or the content of the available properties.
7. Add custom IFC data using the Create Property/Classification option if needed (see above).
8. Drag and drop IFC Entities into the New Relation folder from the containment tree.
Note:
• The Entity types that can be dragged into the new Assignment depend on the Assignment 

type.
• For example, you can only group IfcSpaces (ArchiCAD Zones) into an IFC Zone; while you 

can group both IfcSpaces and already existing IFC Zones within a Space Occupant 
(IfcOccupant). The latter case demonstrates that  the member of an Assignment can itself 
serve as an Assignment itself.

• If needed, define a new name for the relation (see step 8) on the right side of the dialog in the 
Name Attribute field.

• Use the Delete (red X) button to delete a Relation or Assignment.
• The export of Space Occupant data is not allowed due to Coordination View restrictions, so 

such data can be exported only in Extended Model View.
See IFC Assignments.
See IFC View Definition in Export Options.
Examples:
• Create an IfcZone named “Security Zone”, which will group together all of the project’s 

IfcSpaces that have a security function.
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• Define the Project Architect as an Actor, whose only element is the IfcProject, with an Actor 
Attribute of “Person”.
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• Using a new Space Occupant, group together all the IfcSpaces whose owner is an 
Organization.

Predefined Rules
You can assign new IFC data to selected elements based on automatic (.xml-based) rules, using 
the Apply Predefined Rule button. There are three types of such rules, based on their differing 
structures:
• “Tree list” rule: select an element from a tree-structure database to create the new data
• “Table” rule: select a row from a table to create the new data
• “Command” rule: Start the rule-command to create the new data
The program contains factory-defined built-in rules (these vary depending on your localized 
version of ArchiCAD). As an example, the following table summarizes the rules that are 
contained in every language version of ArchiCAD:

Rule name Related object Rule Type Function New IFC data

GSA - Building 
Elements (OmniClass)

IfcElement* Tree list Category classification 
(OmniClass table 21-
’Elements’)

Classification 
Reference

GSA - Building 
Elements (UniFormat)

IfcElement* Tree list Category classification 
(UniFormat II)

Classification 
Reference
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Examples:
• Apply the GSA - Project Client/Owner and Architect command on the (Ifc)Project selected in 

IFC Manager. As a result, Actors are created with the following relations: Project Client/
Owner and Project Architect.

GSA - Construction 
Entities by Function 
(OmniClass)

IfcBuilding/
Storey

Tree list Functional classification 
(OmniClass table 11-
’Construction Entities by 
Function’)

Classification 
Reference

GSA - Occupant 
Properties (CDB-
2010)

IfcOccupant Table Classification of 
organizations (CDB-
2010-’Occupant 
Properties Lookup 
Table’)

Classification 
Reference, custom 
IFC Property

GSA - Products 
(OmniClass)

IfcElement* Tree list Construction product 
classes (OmniClass table 
23-’Products’)   

Classification 
Reference

GSA - Project Client/
Owner and Architect

IfcProject Command GSA-required Actor-
assignment to the project 

Actor

GSA - Space by 
Function (OmniClass)

IfcSpace Tree list Functional classification 
(OmniClass table 13-
’Space by Function’)

Classification 
Reference

GSA - Space Category 
(BOMA)

IfcSpace Table Category classification 
(BOMA)

Classification 
Reference

GSA - Space Category 
(Owner)

IfcSpace Table Category classification 
(GSA’s STAR Space 
Category) 

Classification 
Reference

GSA - Space Type 
(Owner)

IfcSpace Table Type classification 
(GSA’s STAR Space 
Type)

Classification 
Reference

Rule name Related object Rule Type Function New IFC data
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• Assign a Space Occupant classification by using the GSA - Occupant Properties (CDB-2010) 
rule:

1. Create the new Space Occupant (see above at Assignments), then drag in the elements that 
belong to it (e.g. IfcSpace entities).

2. Select the Space Occupant name, then use the Apply Predefined Rule tool. From the dialog 
box, choose the GSA - Occupant Properties (CDB-2010) rule.

3. From the table, select the desired classification item.
4. Click Apply. The Classification Reference elements and custom Properties are generated for 

the Space Occupant, using the values corresponding to the selected classification item.
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You can search among the rules in the databases (tree list and table) by entering any partial text.
For example, let us assign classifications to a number of roof slabs (IfcSlabs) using the GSA - 
Building Elements (UniFormat) rule: 
1. In the model, select the Slab elements to be classified (you can use Find & Select). Open the 

Settings dialog box and click on Manage IFC Properties from the Tags and Categories Panel. 
Alternatively, select the corresponding IfcSlab entities from the IFC Manager containment 
tree.

2. Use the Apply Predefined Rule tool. From the dialog box, choose the GSA - Building 
Elements (UniFormat) rule.

3. In the database search field, enter the text “roof”.
4. From the Search results area, select the Flat Roof Construction title. As a result, the same item 

will be selected in the tree list.
5. Click Apply. The Classification Reference is generated, with the name of Flat Roof 

Construction, with an ItemReference value of B1021, and additional data corresponding to the 
UniFormat standard.
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Note:
• Once you select an element, only the applicable rules are available in the Select Rule list 

(for example, if you have selected IfcProject, then the GSA - Project Client/Owner and 
Architect rule is available). All the non-applicable rules are grayed.

• IfcElement includes building, distribution (MEP) and furnishing elements.
• Certain rules are not available in Settings dialogs if the rules are related to elements (for 

example, IfcBuilding, IfcBuilding Storey, IfcOccupant, IfcProject) which do not have 
Settings dialogs.

• You can create and edit your own rule in .xml format. It is recommended to peruse the 
structure of an existing rule file (which may contain multiple rules), and to create a similar 
new rule by duplicating it under a different name.

• The available rules are accessible from the following folder, and the newly created rules 
should also be saved to this location: 
- On Windows: 

\Users\user name\GRAPHISOFT\IFC Rules “ArchiCAD version”
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- On MacOS: 
/Users/user name/Library/Application Support/GRAPHISOFT/IFC Rules “ArchiCAD 
version”
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IFC Scheme Setup
Custom IFC Property data (but not Classification Reference data) can be stored in so-called 
Schemes (.xml files). Use the IFC Scheme Setup command (File > File Special > IFC 2x3 > IFC 
Scheme Setup) to manage these schemes, using the following functions:
Use the Get Current Project Settings button to collect all the current custom Property Sets and 
the IFC Properties (defined in either IFC Manager or Element Settings) which they contain.

Note:
• As part of this process of collecting data, if a custom Property already exists for at least 

one element (e.g. one IfcWall element) of an IFC Entity type (IFC Element Type), then the 
custom Property will appear as a property of that IFC Entity (e.g. IfcWall).

• Derived custom Properties (such as those derived from the current Conversion rule applied 
to Library parts - see IFC Options) are not shown in the Scheme Properties list, because 
they are not editable, and are exported as part of IFC export.

• The current status of IFC Scheme Setup (i.e., following a Get Current Project Settings 
process) can be saved in an .xml file as part of the Export function, and this file can then be 
merged into a new or existing project.

Hint: If you wish to use the current custom Property data in a new project (so you don’t have 
to redefine them), then use the Get Current Project Settings option on your current project, 
then save the result as an .xml file during Export process, and load it into the new project by 
using Merge.
Note: When you load a Scheme into a new project, that project need not contain the IFC 
Element Types contained in the Scheme. As soon as you create an element in the project 
whose type includes a custom IFC Property according to the applied Scheme, then those data 
immediately appear and are accessible in the element’s Settings dialog (Manage IFC 
Properties), as well as in the Property list belonging to the element in the IFC Manager. The 
appearance of such properties is like that of standard Properties (they are shown in black, with 
a checkbox in front). This means they cannot be edited (renamed or deleted) in either the 
Settings dialog or in IFC Manager, because they are derived from Scheme Setup - that is the 
only place they are editable.
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• At any time, use the Merge function to import a Scheme stored as an .xml file. If the current 
project’s Scheme Setup already contains custom Properties, then the Merge means you will 
retain your existing Properties, and add the new ones from the file. If the current project’s 
Scheme Setup contains custom Properties (with assigned values) that have the same name and 
location (Property Set) as those in the merged Scheme, then the original values will be 
retained in both IFC Manager and Element Settings (the values you assigned will not be lost).

• The currently used Scheme is editable. You can create new custom Property Sets and 
Properties as IFC Element Types (use the Create Property command). You can rename and 
delete Properties (click the red X). You can delete the entire contents of the currently used 
Scheme with the Clear All command. The IFC Element Type tree list (the Scheme Elements 
list on the left side of the dialog box) contains all of the element types - and their “parents”, in 
the IFC 2x3 scheme documentation - that are editable in ArchiCAD (these do not, for 
example, include IfcAnnotation and IfcGrid). The tree list can be filtered by Structural and 
HVAC domains. For example, the Structural domain contains the IfcBuildingElement types 
(IfcBeam, IfcColumn, etc.) while the HVAC domain contains the IfcDistribution types.

Examples:
• Create a label-type “Material” Property (AC_Pset_GeneralData) for every building element.
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• Create an identifier-type “Ventilation Type” Property within the Property Set called 
ePset_SpaceVentilationCriteria.
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Note: 
• The newly created custom Properties are shown in blue for IFC Element Types (e.g. 

IfcWall) if the Property was created at a higher, “parent” level (e.g. IfcBuilding). In this 
case, the Property can only be edited from within the parent (whose name is shown in 
parentheses following the Property name).

• Examples of display variations in the Scheme Elements list:
- IfcWall: IFC Element Types that can appear and are editable in IFC Manager.
- (IfcBuildingElement): IFC Element Types which are the “abstract supertypes” of the 

former (and which do not appear in IFC Manager).
- IfcWall and (IfcBuildingElement): As above, but whose Properties are editable 

(deletable using the red X) in IFC Scheme Setup).
Applying the current Scheme Setup (click Apply) will synchronize all changes and current 
Property elements in the IFC Manager and Settings dialogs.

Example:
Merging and applying the scheme file called “ConceptDesign BIM 2010.xml” (ArchiCAD’s 
default scheme template file, found in ArchiCAD’s Defaults folder) will add the properties 
stored in the template file based on the requirements of GSA, Statsbygg and Senate Properties 
to the default IFC Scheme. This means the merged properties will be available as default 
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custom properties in the current project’s IFC Manager and Element Settings dialogs. (You 
can activate them with the checkbox, but they are not editable.)
If you click Cancel, all changes will revert, and the .xml merge will not be carried out: 
everything remains as it was before you issued the command.
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IFC Options
The settings defined at IFC Options (File > File Special > IFC 2x3 > IFC Options) also affect 
the way that IFC data are created and managed.

 

Person and Organization
Use this option to enter general information about the project owner (Person, Organization and/or 
Person and Organization). This information (IfcOwnerHistory) will be added to each exported 
element.

Note: At model filtering of export/import (by using Model Filter), the IFC elements can be 
grouped by the Person name of the Owner information (called Element Owner) set here or 
received from other applications.

See Model Filter.

Configuration of extended library part items
Use these controls (check the box) to convert selected or all parameters of ArchiCAD Library 
Parts (Object, Door, Window, Skylight, Stair, Zone and Lamp) to IFC Properties. In essence, this 
is a mapping process that is carried out according to an applied configuration file (mapping rule). 
Since the configuration file is editable (see later), this option allows you to do the following:
• to store the library part parameters as custom IFC Properties (in custom Property Sets) by 

default, and to prepare them for export;
• to prepare certain library part parameters to be stored and exported as standard IFC Properties 

(in standard Property Sets), if a corresponding parameter exists in the IFC 2x3 scheme 
documentation (for example, ArchiCAD’s “Fire Rating” parameter corresponds to the 
standard IFC property “FireRating”);
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• to harmonize library part parameters with IFC Properties handled by other applications’ 
import/export processes. This means that the conversion file used in IFC Options will be 
considered by ArchiCAD’s IFC import processes (Open/Merge, Detect IFC Model Changes 
and Update with IFC Model) and Detect IFC Model Changes), so that - for example - the 
custom Properties of an IfcSpace (such as a Revit Room) imported from another program will 
be mapped to the values of an ArchiCAD Zone library part.

Several configuration files (using the extension .xml) can be created and saved (New), browsed 
for (Browse) or modified (Edit). The mapping process always relies upon a single configuration 
file that is selected here and whose name is displayed in the Configuration file path field.
When creating a new configuration file or editing an existing one, you will use the appearing 
dialog box with the following main controls.

The Object list at the top left displays the libraries currently loaded in the project (Folder View). 
You can change among the following views: Folder View (used Objects only) and Search criteria, 
which enable you to search for an object based on numerous criteria.
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The list at the lower left (Available Parameters) displays all the parameters of the Library Part 
selected from the list above. (In Folder View, if multiple objects are selected, this list is empty.)
The configuration list on the right shows those parameters whose conversion to IFC Properties 
will take place using the current configuration file. Parameters can be placed in this list in the 
following ways: 
• by dragging any or all parameters of multiple selected Library Parts into this list, or by 

clicking the Add All Parameters button;
• or, if a single Library is selected, by dragging any or all of its parameters into the list, or by 

clicking Add Parameters.
In the configuration list, all parameters belonging to a particular Library Part are stored in their 
own custom Property Set (AC_Pset_ “Library Part name”), using the IFC Property name that 
corresponds to the parameter’s localized name. The IFC Element Type (such as IfcDoor) is 
automatically created based on the Object’s GDL subtype, and can be modified as needed (it can 
be re-classified as any IFC Entity).
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Example: We have assigned the Cost and Fire Rating parameters to a Door, using the Door 
Settings dialog box. We want to export these parameters (and their values) as custom IFC 
Properties, together with the Door, to an IFC file. All we need to do is drag the two parameters 
of the Door into the Configuration list. The values of the Door parameters will be assigned to 
these IFC Properties during export. You can see the result, for example, by using an IFC 
model viewer/checker.
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To complete and save the configuration file in .xml format, click Save. The Save button is active 
if you have activated the Use configuration of extended library part items in the IFC Options 
dialog box, and if the file is shown in the “Configuration file path” field.

Note: The chosen configuration file is also used when you save additional custom Property 
Sets (Derived Model Data to Export > All Library Part properties as Custom Property 
Set).

As needed, you can modify the names of the previously mapped IFC Properties and Property Sets  
in the configuration list. This way, you can export certain parameters as standard IFC Properties. 
(ArchiCAD uses the configuration file during the import process, too: you can pair incoming 
custom Properties with their counterparts in ArchiCAD, if any exist. For example, if a custom 
IfcSpace arrives from Revit, you can define which ArchiCAD Zone parameters should 
correspond to those IFC Properties.)
Example: We would like to export a Fire Rating parameter, which is assigned to a Door, as a 
standard IFC Property. This is possible, since this parameter has a counterpart in the IFC 2x3 
scheme documentation, namely “FireRating,” in the “Pset_DoorCommon” Property Set. All we 
need to do is rename the existing IFC Property Set and IFC Property accordingly.

Using the configuration file to map parameters will immediately take effect in the current project: 
the corresponding IFC Properties and Property Sets will appear as derived data in the Settings 
dialog box of the affected Library Part, as well as in the IFC Manager, if the Library Part is 
selected.

IFC Manager Tree View
Use this control to vary the tree view used by the IFC Manager. If the ArchiCAD model (even 
after IFC model import) contains ArchiCAD Zones (IfcSpaces) which contain Objects (such as 
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MEP elements, furnishing, etc.), then you can switch the view of the IFC Manager’s containment 
tree to a view (called Space Containment) which lists the Object content belonging to each 
IfcSpace.

Note: Space Containment tree view is only a visualization mode in the IFC Manager. But if 
you would like to export this AC Zone (IfcSpace) relation of the elements, you have to check 
the "Space containment" option for the export at the "Derived model data to export" options of 
the used IFC Translator.

      See Export Options.

IFC Interface language
The standard language of IFC 2x3 is English, thus the default and recommended setting for the 
interface is English. In localized ArchiCAD versions, some standard IFC key words (such as IFC 
Entity, Property, Attribute names) may be shown in the local language, but this has no effect on 
the IFC export, just helps users comprehend IFC terms on the interface.

Express Data Manager (EDM) path
The EDM (Express Data Manager) toolkit is the engine which creates an ArchiCAD model from 
the imported IFC model, and which also creates an IFC file out of the exported ArchiCAD model. 
The default engine is the recommended one, but you can use the Redefine option here to modify it 
as needed.
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Find and Select Elements by IFC Data
Use the Find & Select function to locate and select elements that match criteria based on the 
elements’ IFC data (IFC Properties and Classification References).
1. In the Find & Select dialog box (Edit > Find & Select), click the Add pop-up to access 

additional criteria.
2. From the pop-up, choose Add IFC Properties.
3. The Select IFC Properties dialog box appears.

All IFC data added to project elements (derived and checked in Element Settings dialog box 
or IFC Manager) are listed here. (This data will therefore be exported if the project is saved in 
IFC format).

4. You may narrow the entire available IFC data list:
• to available IFC data of a chosen IFC Element Type; and/or
• to searched IFC data by typing any text string in the Filter list field

Note: In filtering by IFC Element Type, the “All” option means all IFC Element Types which 
exist in the current project (i.e., is visible in the IFC Manager).

5. Click on the listed IFC data that you want to use as search criteria in the Find & Select dialog 
box. Multiselection is available. If you select a Property Set in the list, then all of the 
Properties it contains are added to the criteria. Similarly, if you select an Attributes folder or a 
Classification Reference folder, then all the items contained in the folder are added to the 
criteria.

6. Click Add as Criteria to return to the Find & Select dialog box. All selected IFC data is now 
added as search criteria.
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7. Define operators and values for the criteria according to their type (label, integer, boolean 
etc.). (You may get values for the IFC data criteria from the model by applying the Pick Up 
Settings and Copy Settings tools to the owner element of the same IFC data type.)

8. Click the Plus button to execute the Find & Select function.

You can also use Find & Select to search by IFC Element Type. Its criteria list is divided between 
all types available in the project (above the line) and all types that can be displayed and modeled 
in ArchiCAD (below the line). This means that you can create so-called Criteria Sets even for 
elements that have not yet actually be placed in the current project.

Note: IFC Element Type is also determined by Element Classification. For example, if in a 
given view, and with the Element Type criterion set to “All Types”, you search for IfcBeam as 
the IFC Element Type, then the program will select all of the Beam elements visible in the 
current view whose Element Classification is set to “ArchiCAD Type”, plus all other elements 
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created with other tools that have been assigned “Beam” as their Element Classification (such 
as a curved Beam drawn using the Wall tool).

The IFC Element Type’s criteria list includes all so-called “parent” element type (these are 
collector entities that are above the other elements in the IFC entity hierarchy). For example, if 
your sole criterion is IfcBuilding, you can, with a single click, select just the building elements 
(IfcBeam, IfcColumn, IfcSlab) from among all the elements in the current view - while leaving 
out the other elements (like MEP and furnishings).
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Scheduling Elements with IFC Data
Use ArchiCAD’s Interactive Element Schedule to list IFC data assigned to  project elements. The 
fastest way to create a new Element Schedule is to use the New Schedule command, available if 
you right-click the Element item in the Navigator.

As with the Find & Select function, you can use IFC data as element criteria when creating an 
Interactive Schedule. IFC data include Property, Classification Reference, and IFC Element Type.
In the Schedule Field, you can use the following IFC data:

- IFC Element Type (use the Add button from the list of General parameters)
- Any other IFC data (Property and Classification Reference) that exist in the project (use the 
Add IFC Properties button from the Add pop-up).

When you choose these criteria, the process is similar to that described under Find & Select (see 
previous chapter). Here, too, multisection is available; and if you select a Property Set from the 
list, then all of the Properties it contains are added as fields. Clicking OK in the Scheme Settings 
dialog, the program automatically generates a schedule with the Field elements and their values.
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Export Functions
There are two export functions to choose from: 
• Save as (File): exports the entire current ArchiCAD project or just its filtered content to an 

entirely new IFC file.
• Merge to IFC Model (File > File Special > IFC 2x3): enables you to merge only certain IFC 

elements (model filtering) or, alternatively, the entire content of the current ArchiCAD project 
into an existing (unopened) IFC file. For example, use this command if you want to add 
selected content from an ArchiCAD model to an IFC file from another discipline (MEP-
system, structural model etc.) that was created for the same project.
For example, this illustration shows the result of merging an ArchiCAD model into an existing 
file that contains an MEP model.

Note: In case of Merge to IFC Model, the content of the existing IFC file is protected: 
merging a file to IFC will only add to it, without replacing any of it. This means that if an 
element to be merged has the same IFC GlobalId as an existing element in the IFC file, then 
the ArchiCAD element will be merged using a new IFC GlobalId. Thus, elements will never 
be overwritten as a result of a merge. This also means that the Merge to IFC Model command 
is not suitable for merging changes from one version of an IFC file to another version of the 
same file!

During both export processes, the IFC model will be generated from the selected ArchiCAD 
elements by mapping them according to the elements’ default type, or according to the elements’ 
user-defined classification.
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The export processes are always assisted by predefined translators, whose default settings you 
can modify or overwrite as you go.
See IFC Translators.

Filtering elements for export can be carried out using the following criteria:
• The selected elements in the current view.
• The visible elements, based on display settings (Layers, Partial Structure display, etc.) in the 

current view (the view that was open when you issued the Save as command).
• The entire model with the current view’s display setting, regardless of any selection or layer 

settings.
Note: In order to export 2D drawing-type elements, annotation element or Grid elements, it is 
not enough to meet the criteria of the filters listed above (e.g. export based on selected or 
visible elements); you must also specifically enable the export of these elements in the 
“Model Element Filter” of the translator being used.

The filter to be applied may depend upon any of the following:
• the default filters in the translator,
• any manual resetting of the filters using the Export pop-up in the export dialog box (this 

allows you to filter only the elements in the currently open view),
• any further filtering set up in the Model Filter (e.g. all model elements, or all visible elements, 

or all selected columns).
See Model Filter.
Follow these steps to export IFC data:

Step 1: Choose IFC File Format to which to Export (Save as type)
From the Save as type field, choose the desired IFC file format for export.
See File Types.
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Step 2: Choose IFC Translator
Exporting IFC elements occurs in conformity with the settings of the selected translator. Use the 
drop-down list to choose among the predefined or user-defined translators. The default translator 
for export from ArchiCAD is shown by default. Use the Settings button to edit a translator’s 
settings, or to create a new translator.
See IFC Translators for details on these settings.
To quickly adjust the element filters for the current export - without modifying the translator’s 
default settings - use the Export option in the export dialog box, or the Model Filter function.
See Model Filter.

Step 3: Modify Element Filters as Needed (Export)
Possible filters:
• Selected elements only (available only if elements have been selected)

Elements selected in the current view (the view that was open when you issued the export 
command) will be exported.

• Entire project
The entire model (regardless of any selection, and regardless of the elements’ show/hide 
status) will be exported.

• Visible elements (on all stories)
The visible elements in the current view will be exported, regardless of any selection. 
(“Visible” means all elements that are set to be displayed (due to layer settings, model view 
options, partial structure display, etc.).)
Note: If you issue the export command from Floor Plan view (“Visible elements (on all 
stories)”) means all elements currently displayed on every story of the project.

• All elements on current story (available only if Floor Plan is open)
All elements (regardless of any selection, and regardless of the elements’ show/hide status) on 
the current story of the Floor Plan will be exported.

• Visible elements on current story (available only if Floor Plan is open)
All elements (regardless of any selection) that are visible on the current story of the Floor Plan 
will be exported.

Step 4: Model Filter (use as needed)
See Model Filter.

Step 5: File Name
Use the File name field to define (Save as) or choose (Merge to IFC Model) the file name you 
wish to export. then click Save.

Step 6: Export
Click Save (Save as) or Open (Merge to IFC Model) to start the export process.
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Hint: After exporting an IFC model, it is good practice to check the IFC model in an IFC viewer 
(or in ArchiCAD by reopening the IFC file). There are many free IFC viewers on the market that 
can be readily downloaded, including:
• DDS-CAD Viewer: http://www.dds-cad.net
• Nemetschek IFC Viewer: http://www.nemetschek.com
• Solibri Model Viewer: http://www.solibri.com
• Tekla BIMsight: http://www.teklabimsight.com
60 IFC 2x3 Reference Guide

http://www.dds-cad.net
http://www.nemetschek.com/en/home/the_company/strategy_philosophy/innovation.html
http://www.solibri.com
http://www.teklabimsight.com


Import Functions
There are four import functions to choose from:
• Open (File): opens the entire model or filtered parts of an IFC file as a new project. 

ArchiCAD will transform the imported elements (e.g. IfcWall) into the corresponding 
ArchiCAD elements (e.g. Wall).

• Merge (File > File Special): is available only in Floor Plan view, and inserts a received IFC 
model in whole or in part into a running ArchiCAD project. Merge preserves your running 
project, without overwriting its data (this is the “Reference model” concept). So the program 
always automatically generates new IFC GlobalId values for all imported elements to avoid 
overwriting the IFC GlobalIDs of the host project. However, even in this “Reference model”, 
the merged elements are real ArchiCAD elements based on the IFC-ArchiCAD mapping 
convention.

See IFC Element Types.
The process of merging an IFC file is similar to merging another PLN file to ArchiCAD: for 
example, you will define how to place the incoming stories into the existing story structure.

• Detect IFC Model Changes (File > File Special > IFC 2x3): detects the geometric 
differences between two versions (IFC files) of a single model, and merges the modifications 
(new, deleted and modified elements) only into the currently running project.

• Update with IFC Model (File > File Special > IFC 2x3): Updates the current project content 
with an IFC model (an IFC file), according to one of the two functions that follow:
- Import new elements and update existing IFC properties:
The function merges new elements of the IFC file into the project. “New element” means that 
it exists only in the IFC file and has no equivalent (with the same IFC GlobalId) in the current 
ArchiCAD project. It also updates the IFC data (except the geometry) of the modified 
elements. “Modified element” means that it (that is, its IFC GlobalId) exists both in the IFC 
file and in the ArchiCAD project. “Update IFC data” means that the IFC Attribute, Property 
and Classification Reference Data of the modified elements are completely overwritten by the 
data coming from the IFC file. 
Note: This function is not a full-fledged update, since elements that do not exist in the IFC file 
are not deleted from the current ArchiCAD file. In other words, the current ArchiCAD project 
is protected from having its content deleted; its content is extended or modified, never deleted.
- Update IFC properties only:
As in the previous function, but only updates the IFC data (except the geometry) of the 
“modified elements”. For example: the Property content and values of the Zones in an 
ArchiCAD project are replaced by the IFC Properties saved with the same Zones (IfcSpaces) 
of another (e.g. Zone-management) application. (Same Zones means having the same IFC 
GlobalId.)
Since the Detect IFC Model Changes command is more complex than the other two and has 
other functions apart from import (e.g. managing and displaying changes), it is discussed in a 
separate chapter.

See Change Detection.
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The current chapter discusses the Open, Merge and Update with IFC Model commands.
Notes:
• Only the Open process will retain the original IFC GlobalIds of the imported model 

elements. However, if the opened IFC file is saved as an ArchiCAD PLN, and then 
hotlinked, ArchiCAD will change the IFC GlobalId values, to protect the elements of the 
host project (again, in line with the Reference model concept).

• 2D drawing, annotation (IfcAnnotation), and Grid (IfcGridAxis) elements are merged 
from an IFC file only if their import is enabled in the “Model Element Filter” settings of 
the applied IFC Translator.

• It is recommended that you save the ArchiCAD file before merging an IFC file.
• When importing a model, you may find that some elements - though defined as IfcWall, 

IfcSlab, etc. - will be imported to ArchiCAD as Objects (and not as Walls, Slabs, etc.). The 
reason is that their geometric representation is set to the simple “face-based surface” or 
“boundary representation” (BREP). This means that, apart from the element geometry, the 
element does not include information such as its reference axis. In the absence of such 
information, ArchiCAD interprets such “simplified” elements as Objects (with Wall-, 
Slab-, etc. subtype). Nevertheless, these elements will appear as “Wall” or “Slab” in the 
IFC settings interface in ArchiCAD or in an IFC Viewer, which display element types. 
With IFC viewers, you should check these elements’ geometric representations, such as 
face-based surface (ArchiCAD Object) or extruded (ArchiCAD Wall, Slab, etc.) In some 
cases, ArchiCAD’s import engine is able to handle imported BREP elements and attempts 
to convert them into real ArchiCAD elements, primarily Slabs or Roofs.

In all import types, both element geometry and IFC data are imported. Some of these are stored 
with the element as ArchiCAD Attributes, others as IFC Attributes, as standard or custom IFC 
Properties and Classification Reference items.
See IFC Data Types.
Imported IFC data can be checked in the Settings dialogs of the imported elements and in the IFC 
Manager. Find & Select and Interactive Element Schedule also work for/with the imported IFC 
data.
See Working with IFC Data.
Imported elements can be placed onto particular layers in ArchiCAD, as defined in the applied 
IFC translator. For example, in the case of a Merge, you can place the imported IFC model 
elements onto one or more new layers, keeping them separate from the elements of the running 
project.
Follow these steps to import IFC data using the Open, Merge and Update with IFC Model 
processes.
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Step 1: Choose IFC File Format to Import
In the Open or Merge dialog box, choose the IFC file format corresponding to the file to be 
imported.
See File Types.

Step 2: Choose File to Import

Step 3: Choose Translator
Importing IFC elements occurs in conformity with the settings of the selected translator. Use the 
drop-down list to choose among the predefined or user-defined translators. The default translator 
for import to ArchiCAD is shown by default. Use the Settings button to edit a translator’s settings, 
or to create a new translator.
See IFC Translators.
Click Open to import the IFC model. Additional steps follow, depending on the type of imported 
model and the chosen import method.

Step 4: Building or Site Selection
If the IFC file contains multiple IfcBuildings and/or IfcSites, then a Building/Site Selection dialog 
appears. In case of a building, you have to choose a building since the import process can import 
only one building at a time (see the next figure).
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On the left of this selection dialog, view the site and building hierarchy in the tree structure. At 
right, information is shown on each selected building. If the “Import all Site geometry” option is 
not enabled, then the selected IfcBuilding will be imported with only the IfcSite geometry which 
is assigned to the building. To import the entire site model, regardless of the chosen building, 
activate the “Import all Site geometry” option.

Step 5: Filtering Input Content
This is an optional setting that is available if the “Show Model Filter on import” option is 
activated on the translator’s Import Options tab page. The Model Filter allows you to ignore the 
translator’s default settings and to apply custom element filters to the current import process (e.g. 
import just IfcColumns, or just the Ground Floor elements, or just the structural elements 
(IfcBuildingElement) or HVAC elements (IfcDistributionElement), or just elements, such as 
certain IfcColumns, selected from the model hierarchy, or any selection achieved by using filters 
- such as certain columns on the first floor only).
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See Model Filter.

Step 6: Story Matching (only at Merge)
When using Merge IFC (as when merging a PLN), you must define the story of the receiving 
project on which to place the story structure of the incoming IFC data. (The physical height and 
relative elevations of the elements will not change.) In the appearing “Match Stories” dialog box, 
“Current Story” refers to the story of the running project which was active when you issued the 
Merge command. From the pop-up menu, choose the story of the incoming IFC project which 
should be placed onto the current story. In the list, each story of the IFC model is shown with its 
own elevation in parentheses. If you want to change the physical height of the imported story 
structure, you can do so by entering a positive or negative value in the Elevation offset field. By 
default (and this is recommended), the Elevation offset value is the absolute difference between 
the elevation values of the chosen IFC model story and the current ArchiCAD story. A story’s 
absolute elevation is shown in parentheses after its story name.
The result of merging stories: the story structure of the original project remains intact (it is not 
overwritten by the newly merged content), and new stories are created only above or below the 
existing ones (according to the IFC model).

Note: If the imported IFC file contains only a single story (as with IFC files saved in Tekla 
Structures), then the story chooser option is grayed, and that IFC story is used. During Merge, 
the elements will end up in the right place if you issue the Merge command from the Floor 
Plan view of the ArchiCAD story that corresponds to the right position, if such a story exists. 
If not, and if the current ArchiCAD story is in a different position, then use the default 
Elevation offset value (the difference between the stories’ absolute elevations).
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Change Detection
The Detect IFC Model Changes function (File > File Special > IFC 2x3) detects the geometric 
differences between two versions of a single model that has been exported as IFC - that is, it 
compares two IFC files that are two versions of the same project. The elements affected by the 
modifications are generated and merged into the currently running project (that project can also 
be an empty one). Modifications can be viewed and managed using ArchiCAD’s Mark-Up tool in 
both 2D and 3D views.

Naturally, you can restrict the change detection to only a part of the model (for example, to 
elements on the ground floor) or to particular element types (for example, just columns). Since the 
two file versions differ by timestamp, the following geometric differences are detected:
• New Elements: elements created in the newer version that did not exist in the earlier version.
• Deleted Elements: elements that existed in the earlier version but were deleted from the 

newer version.
• Modified Elements: elements that have been modified (in their position and/or size) from 

one version to the next.
Notes:
• It is important that the two IFC files being compared originate from a single application 

and a single project, because the comparison process (more specifically, the pairing of the 
modified elements) is based upon the elements’ GlobalId numbers in the IFC model. If 
there are no identical IFC GlobalIds in the two versions, then all elements will be 
considered either new or deleted.

• It is also important that you correctly identify which IFC file is the older project version 
and which the newer version.
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• The change detection applies only to 3D elements - not to any of the 2D IfcAnnotation 
(lines, texts, fills etc.) and IfcGridAxis elements that may be stored in the IFC file.

• Since the changes are merged into the current ArchiCAD project, we recommend that you 
save the ArchiCAD project before using the Detect IFC Model Changes command.

Hint: Independently of any model exchange workflow with other applications, the Detect IFC 
Model Changes function can also be used to compare two versions of an ArchiCAD project: 
you must have saved both versions of the project as IFC files. This works if the export process 
is set to store the GlobalId numbers in each of the two versions.

See Export Options of IFC Translators.
Follow these steps to compare two IFC files:

Step 1: Browse for the two IFC Files
Start the Detect IFC Model Changes command. Use the Browse buttons to locate and select the 
IFC model, noting the order in which the two files were created (“Older” and “Newer”). Keeping 
track of the versions is crucial to ensure the proper detection and interpretation of the changes.

Step 2: Choose Translator
From the pop-up list, choose an IFC Translator.
The Translator shown is the one defined as the default for IFC import. Translator settings which 
will be applied in this process include:
• The “IFC Domain” and “Structural function” Model Element Filters (these are the default 

filters for comparing elements); and
• The Material Conversion (Import Options) settings.
Assigning the elements to layers is not governed by any setting in the translator, but rather set in 
in later step (see Step 4 below).
See IFC Translators.
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Step 3: Define the Element Types to be Compared
Although the translator chosen in Step 2 defines the default filters to be used for the elements 
being compared, you can use the next dialog box to further limit the model. In fact, you can define 
entirely different filters or customize them.
Thus, use this dialog box to optionally narrow the set of elements to be compared in the two files:

• Filtering by IFC Domain: use one of the predefined domain filters to define the element types 
to be compared. The default value here is the IFC Domain (Model Element Filtering) setting 
of the translator chosen above. “All element types” will compare all elements from the two 
files. The “Structural” or “HVAC” domains will consider only IfcBuildingElements (IfcWall, 
IfcBeam, IfcSlab etc.) or IfcDistributionElements, respectively. The “Custom” domain filter 
can be created using the Options button - e.g., you can consider just beams (IfcBeam) or just 
columns (IfcColumn).

• Filtering by Structural Function: if the IFC files to be compared include elements classified by 
Structural Function (that is, LoadBearing IFC Property is assigned to elements), then use this 
setting to filter load-bearing elements, for example as part of a structural-architectural data 
exchange. The default value here is the Structural function (Model Element Filtering) setting 
of the translator chosen above.
Note: You should use this filtering option only if you are certain that your fellow professional, 
with whom you are exchanging data, is using and able to export the LoadBearing IFC 
Property.

• Filtering by Story/Layer/Owner/Element type: the elements of the two files are listed in a tree 
structure under (IFC) Element Type. The initial filtering is carried out by the IFC Domain and 
Structural Function filters set above; this part of the dialog box enables further fine-tuning of 
the filter, by checking or unchecking element types one by one. Elements can be grouped in 
this structure, to make it easier to gain an overview. For example, you can group the element 
types by Story, by Layer, or by both Story and Layer. For example, you can combine an 
element filter with a story filter to compare just columns on the floor plan.
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Step 4: Differentiate Between Elements from Each Version
Based on the filters you have set up, a list will summarize the detected changes, by number and by 
the type of the change. These changes will be merged to ArchiCAD as Mark-Up Entries. To be 
able to differentiate between elements from each of the two versions, the affected elements will 
be placed on a separate layer when they are merged into the current ArchiCAD project. Naturally, 
you can define a different layer name for this purpose than the layer shown by default.

Step 5: Merge Changes to the Project
Click Merge to send the changes to the project with Mark-Up Entries. Only the detected changes 
of the filtered and compared elements (see Step 3) will be merged into the project and placed to 
the selected two different layers (see Step 4).

Step 6: Story Matching
When merging the differences between the IFC file versions, you must define the story of the 
receiving project on which to place the story structure of the incoming IFC data.
If the two files have differing story structures, you must do the story matching for each of them.
See Story Matching at Import Functions.

Step 7: Use Mark-Up tool
The Mark-Up Palette appears automatically and lists the changes as Mark-Up Entries, using three 
mark-up styles: New, Deleted and Modified Elements. Thus, the elements are easily 
distinguishable on screen according to their specific style. Entries can be sorted by Style and by 
their Floor Plan View.
Elements from the two compared models are categorized separately by the Mark-Up function:
• Elements from the older version (that is, the Deleted and Modified elements from the older 

version) are shown as “Correction”
• Elements from the newer version (that is, the New and Modified elements from the newer 

version) are shown as “Highlighted”
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Each of these categories uses different Mark-Up Styles and their elements can be edited 
accordingly.
Functions on the Mark-Up palette enable you to view, select or zoom to the elements in the 
entries.

Hint: The default colors for marking different change types can be modified in the Mark-Up 
Styles palette (Options > Element Attributes).

Since the elements from each of the two model versions are categorized separately in Mark-Up, 
each Modified element entry contains a pair of elements: one element from the older model 
version, shown as “Correction”, and a newer-version element, shown as “Highlighted.” Their 
different colors make it easy to distinguish them. Moreover, each element in the pair is placed on 
a different layer (see Step 4). You can check any element’s layer by reading its Info Tag, which 
appears when you hover your cursor over any element.

Elements detected as changed become part of the project and are placed on separate layers 
depending on their version (older or newer). To each of these elements, the Mark-Up function 
assigns these elements a category: either New, Deleted or Modified.
Now what can you do with them?
• Deleted Element: You can leave it in as part of the project (placing it on a separate layer); or 

you can delete it together with its Mark-Up Entry, by clicking Delete Entry in the Mark-Up 
Palette. You can also use Delete Entry without deleting the elements in the Entry.
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• New Element: Since it has a Highlighted status, deleting its entry will not delete the element, 
it will just lose its Highlighted status. Then you can use the element as you wish (or even 
delete it from the project). A New element will be deleted together with its Mark-Up Entry 
only if you first remove its Highlighted status (click the Remove Highlight button).

• Modified Element: This pair of elements includes one each that is “Old” and “New”, with 
the same options as described above for “Deleted” and “New” elements. That is, if you do a 
Delete Entry, the older-version element can be either retained or deleted, while the newer-
version element will remain intact, while losing its Highlighted status.

Hint: If you delete a Mark-Up Entry by mistake, use Undo.
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IFC Translators
Importing and exporting model data using IFC takes place according to the settings of the 
translator you are using. ArchiCAD provides predefined, factory-default IFC Translators, but you 
can define your own. IFC Translation Setup command (File > File Special > IFC) allows you to 
view or modify translator settings, or to create new translators. The following is a description of 
the settings found in the IFC Translator Setup dialog box:

Available Translators
By default, you will see the predefined translators (offered for structural, MEP and general 
connections) shipped with ArchiCAD. Any newly created translators will also be listed here. The 
program’s default translators for import and export are distinguished by a blue arrow symbol; 
these default translators will be shown when you execute the import or export commands. You 
can define any selected translator as the default (for export and/or import) by using the “Default 
for” icons.
The only way to create a new translator is to first duplicate an existing one (use the Duplicate 
button). Next, use the Rename command to give the copy a new name. The newly renamed 
translator will contain the same settings as the one you duplicated, but you are free to change any 
of the settings.
Each translator is stored in an .xml file; these files can be exchanged among ArchiCAD users, and 
imported into ArchiCAD projects using the Browse option. The “Location” field below shows the 
path of the selected translator’s .xml file.
Use Remove to remove a translator you don’t need from this list.

Notes:
• With Browse you can re-load the translators (removed before) back to the list.
IFC 2x3 Reference Guide 73



• Modifications to translator settings take effect when you click Save Settings & Close.
• If you want a customized translator to revert to its original, factory-default settings, first 

find the original translator file in the \Program Files\GRAPHISOFT\ArchiCAD 
version\Defaults\IFC Translators folder (Windows platform) or /Applications/
GRAPHISOFT/ArchiCAD version/Defaults/IFC Translators folder (MacOS platform), 
then use this file to overwrite the current translator, found at the place given in the 
Location field.

• A translator that is locked cannot be modified; the settings described below cannot be 
changed in this case. However, if you duplicate a locked translator, you can change its 
settings.

Description
This field is a short textual description of the translator currently selected in the list. This field is 
empty for a newly created translator, but you can enter any text you like.
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Model Element Filter

• IFC Domain
Displays the default element-type filter for the selected translator. Use the IFC Domain to 
filter according to the following criteria for IFC import and export: “All” will include all 
elements from the model; “Structural” will include only the structural building elements 
(IfcBuildingElement); “HVAC” will include only the mechanical elements 
(IfcDistributionElement). To see the exact composition of each Domain filter, click Options; 
modifying these options will create a “Custom” filter.
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• Structural function
Use this as an additional (element-level) filter for export and import purposes, which will take 
into account the elements’ Structural Function classification at export and “LoadBearing” IFC 
Property at import.

- “All elements” will not take the elements’ Structural Function classification into 
account.

- “Load-Bearing elements only” means that only those elements classified as “Load-
Bearing Element” will be exported from ArchiCAD to IFC; and only those elements 
having the IFC Property “LoadBearing Element” with “True” value will be imported 
from the IFC file to ArchiCAD.

- “Non-Load-Bearing elements only” means that only those elements classified as “Non-
Load-Bearing elements” will be exported from ArchiCAD to IFC; and only those 
elements having the IFC Property “LoadBearing” with “False” value will be imported 
from the IFC file to ArchiCAD.

         Notes: 
- If no Structural Function classification has taken place in the ArchiCAD project, or if 

you have not finished the classifying process in ArchiCAD, then you should choose 
“All Elements” here: either of the other two settings (“Load-Bearing elements only” or 
“Non-Load-Bearing elements only”) can result an empty IFC file, or one that is missing 
elements you might need.

- The default Model Element Filter set here can be overwritten during the export/import 
process using the Model Filter options.

See Model Filter.
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• Convert annotations and all 2D elements
If you check this box, the export process of the following 2D elements is allowed: Texts, 
Labels, Fills, Lines, Arcs, Circles, Polylines, Splines and all dimension types.
However, the inclusion of 2D elements in the exported file is also affected by the “Export” 
option set in the export IFC dialog boxes.

- If a 3D view is currently active, the 2D elements can be included only if the “Entire 
project” option is used.

- If a Floor Plan is active, the “Visible” option means only the visible 2D elements will be 
saved, and “Selected elements only” means that only the selected 2D elements will be 
saved.

These 2D elements will show up in the IFC scheme structure as IfcAnnotation. Dimensions 
will be exploded into lines and texts, since the IFC 2x3 standard documentation does not 
include a dimension element.
During import, all IfcAnnotation-type elements (including exploded dimension elements) of 
the IFC file will be imported into ArchiCAD and converted into 2D elements (texts and lines) 
by checking the box.

• Convert grid elements
If you check this box, the export process will include the Grid Elements and the grid members 
of the Grid Systems (Design) in the IFC file.
However, the inclusion of grids in the exported file is also affected by the settings of the 
“Export” options in the IFC export dialog boxes. Both in Floor Plan and 3D views, the 
“Visible” option means only the visible grids will be saved, and “Selected elements only” 
means that only the selected grids will be saved.
These grid elements will show up in the IFC structure as IfcGrid.
During import, all IfcGrid elements of the IFC file will be imported into ArchiCAD and 
converted into grouped ArchiCAD Grid Elements by checking the box.
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Import Options
For import, the following options are customizable (provided that the translator is not locked):

• Show Model Filter on import
If this option is active, then - after you issue an import command - the Model Filter window 
will open.

See Model Filter.
This gives you the chance to overwrite, for the purposes of the current import process, the Model 
Element Filter settings of the translator you are using, to fine-tune the elements to be imported 
(e.g. import only certain element types, or just the elements from a certain story).
See Model Element Filter.
• Geometry Conversion

Use Conversion Options to define the geometry creation method (and concurrently the type of 
the ArchiCAD element being created) for the following IFC element types:

- IFC Site: option to import the geometry of the IfcSite, or not (Without geometry option). 
If you opt to import the geometry, then you can further decide whether the created 
element should be an editable Morph or Object.

- IFC elements with complex geometry: When importing IFC Entity elements that cannot 
be modeled using ArchiCAD building elements (e.g. Column, Beam, Wall) due to their 
non-extruded (BREP) nature, you can choose to interpret them as either editable Morph 
elements, with an Element Classification that corresponds to the type of the imported 
element; or as an Object, with a Subtype that corresponds to the type of the imported 
element.

- IFC Distribution Elements (HVAC): as above; make the choice for imported HVAC 
domain element types (IfcDistrubutionElement).

• Place Imported Elements on...
Define the method for placing the imported elements onto ArchiCAD layers.
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- “Imported layers” means that ArchiCAD will create new layers that correspond to the 
IFC layer (IfcPresentationLayerAssignment) names, and will place the imported 
elements onto these layers.

Note: If layers of the same name already exist in ArchiCAD, no new layers are created; the 
imported elements are placed onto the corresponding, existing ArchiCAD layers.
• “Imported layers with extension” will create new ArchiCAD layers corresponding to the 

IFC layers of the imported file, but will add a custom extension (such as “Structural 
Model”) to each of these layer names. The advantage is that, following the file import, you 
will be able to sort the layers by extension in ArchiCAD’s Layer Settings dialog box.

• “A common new layer with name” means that the imported elements will be placed onto a 
newly created, single layer that you define (such as “IFC import” layer). In this case, the 
import will delete the original layer names of the IFC model.

• Material Conversion
It is possible to map the imported IFC materials to a corresponding Cut Fill type in 
ArchiCAD. This is recommended if the ArchiCAD file template or the running project does 
not contain fill types of the same name as those of the imported materials.

1. If the “Use ArchiCAD Fill Type conversion table” option is not checked, then ArchiCAD will 
determine whether the imported IFC material names exist among the ArchiCAD project’s or 
template’s Cut Fills. If they do, then each imported material will be displayed using the 
corresponding Cut Fill. If such fills do not exist, then a single Cut Fill type set (at “Replace 
missing IFC Materials with” option) will be used to display all such imported materials, while 
preserving the original IFC material names.
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2. If the “Use ArchiCAD Fill Type conversion table” option is checked, then the missing IFC 
materials will be displayed using the definitions in the Conversion Table (click “Conversion 
Table” to bring up this dialog). Here, map the Cut Fill types available in your project to the 
names of the imported IFC materials. For example, you might use ArchiCAD’s “Structural 
Concrete” fill to represent all concrete materials entitled “C20” that are imported from a 
structural program. As a result, ArchiCAD will create a new fill type: it is named “C20”, but it 
uses the existing “Structural Concrete” fill pattern (provided, of course, that the ArchiCAD 
project does not yet contain a Cut Fill type entitled “C20”).

If you have not mapped a particular imported material in this Conversion Table, it will 
automatically be displayed using the cut fill defined at “Replace missing IFC Materials with.”
Hints:
• Some of the default translators include predefined Conversion Tables, whose settings you 

are free to expand or edit in the translator’s duplicated copy (provided that the translator is 
not locked).

• You cannot import or export these Conversion Tables as separate .xml files; you must 
import/export them together with entire translator file itself (use Browse to import).
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Export Options
For export, the following options are customizable (provided that the translator is not locked).

• Elements to export
Use the element filter for export to configure the current translator.

See Step 3 at Export Functions.
This value determines the default filter used by the export process, but you can still change the 
filter in the export dialog.
Note: If there are selected elements in the project when you start the export, this control 
automatically changes to “Selected elements only”, regardless of the translator’s default 
setting.

• Derived model data to export
The following options enable you to export additional data in addition to the elements, which 
can be useful for data exchange with energy analysis or cost estimation programs:

- Space containment: Space containment defines the relationship between ArchiCAD 
Zones (IfcSpaces) and Furnishing, Mechanical (HVAC) and other contained elements 
within the space. Check this box if you would like to send the model to a facility 
management application.

- Bounding box: Check this box if you would like to export the dimensions of the building 
elements’ bounding box. 

- Base quantities (length, area and volume): Check this box to add Quantity Takeoff 
parameters to Wall (IfcWall), Column (IfcColumn), Beam (IfcBeam), Slab (IfcSlab, 
predefined type Floor), Roof (IfcSlab, predefined type Roof) and Zone (IfcSlab) 
elements to the IFC model. This data is useful in the Interoperability with cost 
estimation applications.

For example, the following quantities (IfcElementQuantity) can be exported together with 
IfcWall element: Height; Perimeter; Gross volume; Net volume (volume reduced e.g. by 
columns embedded into the wall); Gross Floor Area (doors are not considered); Net Floor 
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Area (area reduced by door footings); Gross Wall Area (openings are not considered); Net 
Wall Area (area reduced by openings).

- All Library Part parameters as custom IFC properties: This option adds all parameters of 
Library Parts (Object, Door, Window, Zone etc.) to the exported IFC file as custom IFC 
Properties (grouped in property set having the prefix “AC_Pset_(Libpart name)”.

Hint:
• If the IFC project is expected to do a “round trip” (you will merge it back into ArchiCAD), 

then it is advantageous to check this box.
• With another advanced tool, you can use customizable rules to export only certain Library 

Part elements. For example, you can export only the Fire rating parameter with Doors and 
Windows.

See IFC Options.
Note: Choosing this option will significantly increase the IFC file size.

- IFC Space boundaries with tolerance between Zones [mm]: ArchiCAD Zones include 
precise geometry data that are useful to thermal calculation software applications. Zones 
are 3D solids in geometrical aspect and in normal cases are bordered by two slabs and 
four walls. Space boundaries define the logical connection between ArchiCAD Zones 
(IfcSpace) and the building elements that enclose them. In practice, Walls, Slabs, Roofs, 
Windows, Doors etc. all have different thermal conductivity properties. If you activate 
the “IFC Space boundaries...” option, ArchiCAD will export Space boundaries and their 
relations (IfcRelSpaceBoundary) together with the Zones (IfcSpace) to the IFC file. In 
other words, ArchiCAD will calculate the position, size and adjacency of the elements 
that border each Zone. ArchiCAD divides the Zone boundaries according to the areas 
defined and cut by connected elements and openings.  The “tolerance between Zones” 
means the maximum distance between neighboring ArchiCAD Zones (for example, the 
thickest wall/slab).
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- ArchiCAD Zone Boundaries as IFC Space classification data: Check this box to export 
the Zone Categories data (Code and Name) of ArchiCAD Zones as their (IfcSpace) IFC 
Classification Reference data (ItemReference and Name).

• IFC View Definition
Choose whether you want to save the IFC model according to the widely used so-called 
“Coordination view” standard, or according to the requirements of other Model View 
Definitions (MVD; e.g. Concept Design BIM 2010) specified by organizations of 
buildingSMART (such as General Services Administration (GSA), Statsbygg, Senate 
Properties). In the latter case, choose “Extended Model View” and define the requested IFC 
File Header (e.g. ConceptDeisgnBIM_2010) in the Extended Model View name field.
Note: The export of Space Occupant data (see IFC Assignments) is not allowed by 
Coordination View restrictions, so it can be exported only in Extended Model View.

See Model View Definitions.
• Surface Geometry (BREP geometries only)

If you would like to export all model elements with BREP (boundary representation) 
geometry only, activate this option. This option also sets “with precise geometry (BREP)” at 
all items of the Complex elements options (see later).
Note: In earlier versions, the Surface Geometry (BREP geometries only) was known as 
Simplified view (BREP only).

• IFC Site geometry
In ArchiCAD, the IfcSite geometry can be created with Mesh elements, with Objects with 
subtype “Ifc2x_Site” and any modeling element (e.g. Slab, Morph) classified (Element 
Classification) as “Site Geometry”. Depending on whether these elements are visible/selected 
in the view from which you begin the export, and depending on your choices at “Export” 
options, these elements will be exported. Use the drop-down list to apply a geometric 
representation to these elements in the IFC model.
Make your choice depending on which kind of site geometry your partner’s application is able 
to read:
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• Boundary representation (BREP): Geometric representation as solid bodies enclosed by 
their superficies and boundary surfaces. BREP is a simple form of boundary 
representation model in which all faces are planar and all edges are straight lines.

• Face-based surface (top surface): Geometric representation of the superficies (top surface) 
only.

• Geometric set (Wireframe): Geometric representation with contours and points.
Note: ArchiCAD is able to import all three kinds of IFC site geometry representations.
• Complex elements

These options apply to the export of special elements and their inter-connections. The possible 
methods of geometry export are the following:
• Extruded geometry: This is the standard IFC geometry representation, which retains the 

elements’ parameter values (such as thickness, height, location of reference line or edge, 
skin structure of composite materials) - however, certain specialized sections are not 
retained. This is the format usually supported by static analysis programs, because while it 
is important to retain and possibly to modify the elements’ parameters, their special cut 
angles (such as the slanted edge of a slab) are not important.

• Precise geometry (BREP): The boundary representation (BREP) method comes closest 
to reproducing the shape of the element, together with its specialized sections and 
connections. However, the element’s parameters are lost, and BREP elements from an 
imported IFC file are transformed into non-editable elements. Since this method provides 
the most exact reproduction of element geometry, it is useful in the “reference model” 
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workflow, which can be most useful for structural editing or preparation programs (such as 
Tekla Structures).

These two IFC geometry methods can be used to represent the following special geometrical 
situations:

• Elements in Solid Element Operations: With the extruded geometry method, elements 
edited with Solid Element Operations will be exported according to their definition 
geometry - for example, without any automatically added intersections. With the BREP 
method, they will be exported as they are displayed in ArchiCAD because of Solid 
Element Operations.

• Walls with complex end connection:
- With the precise geometry (BREP): If you have one non-simple wall (that is, a wall that 

is Slanted, Double Slanted or Complex) connected to another wall of any geometry, then 
both of these walls will be exported with BREP geometry representation. If any two 
connecting walls are not of the same height, then both of these walls will be exported 
with BREP geometry representation.

- With the Extruded geometry method: Most walls will be exported using the extruded 
geometry representation, if the wall’s geometry allows for it. Otherwise (as in the case 
of Slanted Curved Walls), they will be exported as BREP.

The difference between BREP and extruded geometry representations is well illustrated by the 
case of a simple straight wall connected to a slanted wall:
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• Non-straight composite walls: The following options affect slanted or double-slanted 
composite walls and those with complex profiles:
- As building element parts: The ArchiCAD Wall element is logically made into an 

IfcWall that includes building element parts. The advantage of this option is that each 
building element is assigned the IFC material or profile that is represented by its cut fill 
in ArchiCAD.

Note: Certain applications (such as Revit Structure) do not support this geometric 
representation, so in that case the next option is recommended.

- As complex profiles: The ArchiCAD wall element is logically made into an IfcWall 
element, to which a profile geometry or material list will be assigned, in the form of an 
IFC material. (The receiving application will not know the precise order of the different 
components/skins.)

Note: This option is affected by the Partial Structure Display currently in effect, if the view’s 
visible elements are being exported. For example, if the “Core Only” Partial Structure Display 
is in effect, then the “As complex profiles” option will have no effect on a slanted composite 
wall that has a single core, because in this case the wall will not count as a composite element.
Note: This option will affect only walls saved as “extruded” - thus, for example, it will not 
have any effect if the Coordination View (Surface Geometry) is being used.

See IFC View Definition.
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• Chained beams: With the extruded geometry method, chained beams will be exported 
according to their definition geometry, without any added automatically intersections. 
With the BREP method, they will be exported as they are displayed in ArchiCAD, 
including the automatic intersections.

• Slabs with slanted edge: With the extruded geometry method, slabs will be exported with 
vertical edges, even though their original geometry included a slanted edge. With the 
BREP method, such slabs will be exported using their correct original geometric 
representation.
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• IFC model units
Choose metric or imperial (Length, Angle, Area and Volume) units for the IFC export.
Note: When doing an import, the imported elements and data are always displayed using 
ArchiCAD’s model unit preference (Options > Project Preferences).

• Global Unique Identifiers (GUID)
The “Keep existing” option means that IFC GlobalIds of elements assigned automatically by 
ArchiCAD will be kept in the exported IFC model. The “Keep existing” option is necessary 
for the efficient use of the Detect IFC Model Changes function.

See Change Detection.
Moreover, this option is also useful for the same reason when using other programs to 
compare two IFC model versions arriving from ArchiCAD. The alternative option is 
“Generate new”. Each new exported IFC file will generate brand new GlobalIds for the 
elements, so that each new exported version is entirely separate from the previous versions.
Note: The Global Unique Identifiers (GUID) settings option has no effect on the Merge to 
IFC Model export process.

See Export Functions.
• IFC file encoding

Use this option to define the character coding used by the .ifc or .ifcZIP file.
See File Types.

- ANSI: This is the default option for compatibility reasons, since earlier ArchiCAD 
versions and many other applications (e.g. structural, MEP) use only ANSI.

- Unicode: The recommended option if you are exchanging an IFC model with a 
receiving application using a different platform (e.g. ArchiCAD on MacOS vs. 
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Windows) or a different language environment (such as a different language version of 
ArchiCAD).

Note: Switch to the Unicode option only if you are certain that your data exchange partner’s 
application supports it.
Note: The Unicode option has no effect when saving to .ifcxml format, because exporting to 
that format always uses UTF 8 coding.
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Model Filter
Each IFC Translator contains defined settings for filtering the elements to be imported or 
exported.
See Model Element Filter.
However, the Model Filter options - which are accessible during the import/export process itself - 
enable you to fine-tune these settings. You can even filter elements one by one from a list. The 
Model Filter function varies depending on whether it is applied during import or export: 
• During export: Model Filter appears in the dialog box of the export command. Based on the 

“Export” settings here (“Selected elements only”, “Visible elements”, etc.), the exportable 
elements are listed: you can now further filter these elements by checking/unchecking their 
boxes.

• During import: The Model Filter can be shown optionally (from Import Options of the applied 
IFC Translator). Model Filter in this case lists all the elements being imported from the IFC 
model, enabling you to further filter them by story or function (e.g. structural or HVAC), or 
one by one.

Model Filter options:

A tree lists the exportable or importable elements. Use this list to further filter the elements to be 
exported/imported.
Element filtering can be made easier by sorting the list items or grouping them as follows (Group 
elements by):
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• IFC Element Type: for example, in case of model import, the IfcWall group contains elements 
exported by an application as IfcWall; and in case of model export, the IfcWall group contains 
ArchiCAD Walls whose classification is set to “ArchiCAD Type”, as well as all other 
elements that are classified as “Wall”.

• Story: IFC element types and elements are listed by their story location in the model (e.g. 
Ground Floor).

• Layer: IFC element types and elements are listed by layer.
• Element Owner: element types and elements are listed according to who created them. (In 

ArchiCAD, you can define this person - the “Model Element Author” - at IFC Options. This 
name is saved in the IFC file as IfcOwnerHistory.)

See IFC Options.
Further element filtration can be done by IFC Domain (Structural (IfcBuildingElement), HVAC 
(IfcDistributionElement) or customized settings) and/or by Structural Function, as described at 
Translator settings.
See IFC Translators.

Note: Filtering by Structural Function works differently for IFC Import and IFC Export: 
• At IFC Import, the filter considers the “LoadBearing” IFC property.
• At IFC Export, the filter considers the ArchiCAD elements’ “Structural Function” 

classification.
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