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Overview
OVERVIEW

Google Earth Connections is an Add-On feature available with ArchiCAD 15 Google Earth Connections 
enables seamless integration amfong ArchiCAD 15, Google Earth and the Google 3D Warehouse.
Whether you want to create presentations of proposed developments, share a building you've designed, or view 
a model in context, you'll find the combination of ArchiCAD, SketchUp, the 3D Warehouse and Google Earth 
a powerful way to express your creativity. 
To use this Add-On, you must have downloaded the Google Earth program (version 5 or newer) onto your 
computer, and you must have access to the Internet through a broadband connection (at least 512 Kbits/sec 
download). The Google Earth Connections Add-On is available for download through the Help menu of 
ArchiCAD 15.
With Google Earth Connections, you can
• Display your ArchiCAD model in its virtual location in Google Earth
See “Send Virtual Building Model to Google Earth” on page 13.
• Provide architectural context for your project, accessing hundreds of detailed models from Google 3D 

Warehouse
See “Importing Objects from Google 3D Warehouse” on page 11.
• Share your model with others by uploading it to Google 3D Warehouse
See “Upload Model to Google 3D Warehouse” on page 14.
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The Google Earth Connections Interface
THE GOOGLE EARTH CONNECTIONS 
INTERFACE

By default, the Google Earth Connections sub-menu is found in ArchiCAD’s File menu.
Note: The automated data exchange between the 64-bit version of ArchiCAD 15 and Google Earth / 
Google Warehouse is limited for technical reasons. Therefore, the Place Google Earth snapshot, Import 
Model from 3D Warehouse, and Upload Model to 3D warehouse commands are not available. The 
suggested manual communication workflow between these programs can be found in the relevant section 
of this document. 
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Registering Location Information in ArchiCAD
REGISTERING LOCATION INFORMATION 
IN ARCHICAD
If you want to use your ArchiCAD model in Google Earth or share it with others on Google 3D Warehouse, 
you should first define the model’s geographical location information. 
ArchiCAD Location information – for the purposes of connecting with Google Earth – is recorded in the 
Google Options dialog box (File > Google Earth Connections). When you first open the dialog box, this 
location information is not yet set. You can click the Add button and then enter location data by hand. 

Often, however, the easier way is to import this information from Google Earth.
There are several ways to load location information:

Note: These operations can be executed only if the Floor Plan window is active. 

1. Import Location Information from the Active 
Google Earth Window 

Note: This method not supported by the 64-bit Google Earth Connection package.
Choose the Google Earth Connections > Place Google Earth Snapshot command. This command 
captures an image of the current Google Earth view; in ArchiCAD, a bounding box appears with the pencil 
cursor. Place the snapshot on the ArchiCAD floor plan. (In ArchiCAD, the snapshot is a Figure with a 
bounding box.)

Note: You may get the following warning:

In this case, go back to Google Earth, zoom in closer to the preferred location, then return to ArchiCAD 
and again issue the “Place Google Earth Snapshot” command.
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Registering Location Information in ArchiCAD
ArchiCAD’s Project Origin is now defined in terms of the geodetic location of the centerpoint of the 
imported Google Earth snapshot; this location information now appears in your Google Options dialog box.

To see the location of your model in Google Earth, click the Show Location in Google Earth button. 
Google Earth now opens with a placemark showing your Project Origin.
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Registering Location Information in ArchiCAD
2. Import Location Information From Google 
Earth Element

Open Google Earth and navigate to the location of your choice. Using Google Earth’s tools, create a 
placemark or polygon to define your location. As you create this element, a dialog box appears where you set 
its properties. 

IMPORTANT: Make sure to set the Altitude property to “Absolute” in Google Earth as shown in the 
image below; otherwise, ArchiCAD will not be able to import the file.

The new element (i.e. placemark or polygon) is listed in the Google Earth tree structure at left; right-click to 
save it as kmz file (i.e. Google Earth’s native format) to a folder of your choice.

Note: If you did not set the altitude of your Google Earth object to Absolute when you created it, select 
its name in the file tree at the left side of your Google Earth screen; right-click to access Properties. 
Change the Altitude parameter to “Absolute.” Then you must re-save this item to its file location (as a kmz 
file) before importing it to ArchiCAD.

Then use the File > Merge command in ArchiCAD or drag-and-drop to merge this file into your project. You 
can also use the File > Open command (this creates a new ArchiCAD project file). 

Note: Use the Element Import Options in Google Options (File > Google Earth Connections) to 
create hotspots for the imported objects. In the same dialog box, you can opt to create ArchiCAD cameras 
that correspond to the object’s view angle in Google Earth. 
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Registering Location Information in ArchiCAD
Location Information Options
If you are using Merge or Drag & Drop to import a Google Earth object, or if you are placing a Google 
Earth snapshot, and if your ArchiCAD project already has location information, a Warning appears, 
providing you three options:

1) Overwrite. Click to place the imported Google Earth item. The imported object’s location information 
will overwrite your project’s existing information. (You can check this by opening File > Google Earth 
Connections > Google Options and reading the new location information.)

2) Place relative. The imported object will be placed in its true location relative to your project origin. 
ArchiCAD will zoom to the newly imported object, which is selected.

3) Ignore imported object’s information. Your Project Location information remains as-is, and you can place 
the imported object anywhere you wish: drag the appearing boundary box and click to place. 
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Importing Objects from Google 3D Warehouse
IMPORTING OBJECTS FROM GOOGLE 3D 
WAREHOUSE

Note: In the 64-bit version of Google Earth Connection, the integrated Warehouse browser is not 
available. On this platform, you should manually download the selected object in an external browser in 
SKP file format, then import it to ArchiCAD 15.

To download models from the 3D Warehouse into ArchiCAD 15, do the following:
1) Activate the Floor Plan window.
2) Select the File > Google Earth Connections > Import Model from 3D Warehouse command.
The Google 3D Warehouse browser appears. Use the 3D Warehouse browser to explore models and find one 
you can use. If you see a model you're interested in, click its name to view a larger image of the model, along 
with details about the model.

Note: Objects containing location information can be identified by the map displayed next to the object.

3) Click “Download Model”. 
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Importing Objects from Google 3D Warehouse
4) If the imported item you selected in 3D Warehouse does not contain location information (for 
example, a piece of furniture), simply click to place it in ArchiCAD using the appearing pencil cursor and 
bounding box – just as when placing an ArchiCAD object.
Note: Use the Element Import Options in Google Options (File > Google Earth Connections) to 
create hotspots for the imported objects. In the same dialog box, you can opt to create ArchiCAD cameras 
that correspond to the object’s view angle at the time it was created in Google Earth. 

5) If the item does contain location information, and your ArchiCAD project does too, then you will have 
the same options as when merging a Google Earth object (see above.)
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Send Virtual Building Model to Google Earth
SEND VIRTUAL BUILDING MODEL TO 
GOOGLE EARTH

1) Once you've finished creating a model in ArchiCAD, save it.
2) Activate the 3D window.

Note: Use the 3D Model Export Options in Google Options (File > Google Earth Connections), check 
the box if you want to recreate ArchiCAD’s current 3D view angle in Google Earth. 

3) Choose the File > Google Earth Connections > Send Virtual Building Model to Google Earth 
command.

4) If your ArchiCAD project already contains a defined Google Earth project location, then Google 
Earth will open. Your model will be placed at the defined location.
Note on Altitude: Use “Set Altitude as” options in the 3D Model Export Options in Google Options 
(File > Google Earth Connections) to determine how your ArchiCAD model will be placed into Google 
Earth. “Absolute” means that your model will be placed at its exact altitude, as defined in ArchiCAD (in 
the Google Options dialog box). “Clamped to ground” means that your model will be placed on the 
ground at the defined location (similar to ArchiCAD’s “Gravity” function). 

5) If your ArchiCAD project does not yet contain location information, a warning appears:
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Upload Model to Google 3D Warehouse
UPLOAD MODEL TO GOOGLE 3D 
WAREHOUSE

Note: In the 64-bit version of Google Earth Connection, the integrated upload client is not available. On 
this platform, you should manually export the object in SKP file format and upload it with a browser to 
the Google 3D Warehouse.

To upload your ArchiCAD model to 3D Warehouse:
1) Once you've finished creating a model in ArchiCAD, save it.
2) Activate the 3D window.
3) Choose the File > Google Earth Connections > Upload Model to 3D Warehouse command.

If your project has no location information, the following warning appears:

If you continue without defining location information, the model will appear in 3D Warehouse without a 
map, and without location information.

4) Next, the 3D Warehouse Upload Options dialog box appears.

The “Elements to Upload” and “Layers to Upload” sections function as filters. This way, you can filter out 
unnecessary or complicated objects by their types and layers. The model complexity indicator is based on the 
number of polygons in the model. A very large number of polygons, indicated by “Complex” on the 
complexity scale, will put considerable demands on your computer's resources and may cause Google Earth to 
run more slowly while the model is displayed.
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Upload Model to Google 3D Warehouse
If the model complexity can’t be reduced by the “filtering” technique, the free Polycount utility (see Q&A 
section) can help identify the most complex ArchiCAD elements in the scene.
The Google Accounts sign-in page opens in the 3D Warehouse browser. Sign in to your Google Account. (If 
you don't have one yet, you can create a new one by clicking “Create an account now.”)
On the “Upload to 3D Warehouse” page, type a title and description for the model.
Optionally, if the model has registered location information, you can add an address in any format. The 
address is used to index the model so that it can be found if users search by address.
For all models you can add:
• A web address for a website that has more information about the model.
• Tags that further categorize the model. Tags are comma-separated keywords or phrases that describe your 

model, such as library, old stone building, converted train depot.
When you are finished adding information about the model, click “Upload.”
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Frequently Asked Questions
FREQUENTLY ASKED QUESTIONS

What is Google 3D Warehouse?
Google 3D Warehouse is web site that lets you search, share, and store 3D models. Anyone may search and 
download models, but to submit your own, you'll need to log in using your Google Account.
The models in the 3D Warehouse include everything for your 3D world: buildings, houses, bridges, statues, 
sculptures, couches, cars, people, pets, and much more.
If the model has a location on earth, for example, a building located in Boulder, Colorado, you can download it 
and view it in Google Earth.

What is Google Earth?
Google Earth is a free-of-charge, downloadable virtual globe program. It maps the earth by the 
superimposition of images obtained from satellite imagery, aerial photography and GIS over a 3D globe.

What is Google SketchUp?
SketchUp is a 3D modeling program designed for professional architects, civil engineers, filmmakers, game 
developers, and related professions. It was designed to be intuitive, fun and flexible, allowing designers to play 
with their designs, unlike most other 3D CAD software.

How Do I Create a Google Account?
To create a Google Account, go to http://www.google.com/accounts/NewAccount, enter your current email address 
and choose a password. Once you've finished registering, you'll receive a verification email. Clicking the link in 
that email will complete the account creation process.

How Do I Create a Model Preview Image for the Google 3D 
Warehouse?
Google Earth Connections automatically creates a preview image for Google 3D Warehouse out of the 
current viewpoint. 

How Do I Revise My Model in the 3D Warehouse?  

The current Google 3D Warehouse Connection package can’t upload a revised model version to Google 3D 
Warehouse. Therefore, you should first manually delete the outdated model version from the Google 3D 
Warehouse (see the How can I delete my model from Google 3D Warehouse? section) and upload the new 
revision from ArchiCAD (see the Uploading models into Google 3D Warehouse section).  

How Do I Delete My Model from Google 3D Warehouse? 
1) Open the http://sketchup.google.com/3dwarehouse page in your Internet browser.
2) In the 3D Warehouse browser, click “Sign In,” and sign into the Google 3D Warehouse with your Google 

Account.
3) In the 3D Warehouse browser, click “My Models.”
4) Find the model you want to remove. 
5) Click “remove.”
6) A message asks you if you're sure you want to remove the model.
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Frequently Asked Questions
How Do I Edit a Model's Information in the 3D Warehouse? 
You can only edit the information (title, description, tags, and so on) for your own models. To edit the 
information for one of your models:
1) Open the http://sketchup.google.com/3dwarehouse page in your Internet browser.
2) In the 3D Warehouse browser, click “Sign In,” and sign into the Google 3D Warehouse with your Google 

Account.
3) In the 3D Warehouse browser, click “My Models.”
4) Find the model you want to change, and then click “edit.”
5) Make your changes. You can change:
• The title.
• The description.
• If the model has a location (in other words, it was created on a Google Earth terrain image):
• The address. You can use any format for the address. The address is used to index the model so that users 

searching on address terms will be able to find it.
• The URL for additional information.
• The tags.
6) When you have finished making your changes, click “Update.”

How Can I Identify the Problematic Elements That Slow 
Down Google Earth?
Check your model with the Polycount utility. This tool (available from GRAPHISOFT’s website at 
http://www.graphisoft.com/support/archicad/downloads/ac15/INT.html) helps you control the number of 3D 
polygons in your ArchiCAD models. Polycount can display the number of 3D polygons grouped by element 
types (walls, slabs doors, windows, objects etc.) and also compute their percentage of the complete model size. 
The add-on also allows you to change the 3D detail level of library parts in your projects.

Which Other Techniques are Available to Reduce the 
Number of Polygons in my ArchiCAD Model?
Make layer combinations. They allow you to show only those elements of the Virtual Building model that 
you currently need to see in the active 3D window. This way, you can easily turn off all elements located in the 
building’s interior, which are thus invisible.  
Control the objects’ level of detail. Most library parts in the ArchiCAD library have parameters for 3D detail 
level (simple, detailed, off) and curve resolution. Set these parameters to the minimum required for the 3D 
view.
Avoid using memory-intensive library part options. Some optional elements of ArchiCAD objects can 
generate a significant number of 3D polygons without producing noticeable differences on the final drawings. 
Please be careful using the following parameters:
• Handles for doors and windows
• Curved railings on stairs (including StairMaker stairs)
• Too many leaves for plant objects
Google Earth Connections for ArchiCAD 15 17
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Frequently Asked Questions
How Do I Find Locations in Google Earth where 3D Models 
are Available?
To find locations in Google Earth where 3D models are available, download the 3D Warehouse Network Link 
(http://earth.google.com/3d.html). Warehouse Network link is a KMZ file used by Google Earth. Once you've 
downloaded the file and opened Google Earth, you'll see special house-shaped markers that indicate where 3D 
models are located.
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Useful Links
USEFUL LINKS

Google 3D Warehouse:
http://sketchup.google.com/3dwarehouse

Google account registration:
http://www.google.com/accounts/NewAccount

Google 3D Warehouse Network Link:
http://earth.google.com/3d.html
Warehouse Network link is a KMZ file used by Google Earth. Once you've downloaded the file and open 
Google Earth, you'll see special house-shaped markers that indicate where 3D models are located. 

Google Earth program: 
http://earth.google.com/download-earth-advanced.html

SketchUp program: 
http://sketchup.google.com/

Online SketchUp object libraries: 
http://www.objectsonline.com/index.php?browse_cat=7
http://www.formfonts.com/

Latest ArchiCAD Google Connectivity package:
http://www.graphisoft.com/products/archicad/addons/google_earth/ge_earth_connections_download.html

ArchiCAD user community forum: 
http://archicad-talk.graphisoft.com
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Useful Links
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